Bobcat ZTR excessive deck belt flapping. Help

Discussion in 'Mechanic and Repair' started by HenryB, Sep 6, 2009.

  1. HenryB

    HenryB LawnSite Bronze Member
    Posts: 1,828

    On my Predator Pro The deck belt snapped. At only 100hrs. I replaced the belt no problem but now I noticed an excess of flap (Shaking) on the long backside closest to me(while seated). Pulleys are all good idlers etc nothing jammed up in pulleys any suggestions. Would a different length belt help shorter or longer?
     
  2. pugs

    pugs LawnSite Gold Member
    Posts: 3,023

    What is the model number of your mower and what is the part number of the belt you put on?
     
  3. Breezmeister

    Breezmeister LawnSite Bronze Member
    Male, from South Jersey
    Posts: 1,489

    Don't know how your belts are set up on the BC, but are you sure you have it routed correctly ? There should be a diagram on the deck some place

    Is it on the right side of the idler

    Have you got the correct belt

    The link here might be of some help

    http://www.bobcatturf.com/
     
  4. HenryB

    HenryB LawnSite Bronze Member
    Posts: 1,828

    Anybody else
     
  5. pugs

    pugs LawnSite Gold Member
    Posts: 3,023

    The belt number you PMed me isnt a valid part number. Might be missing a digit or something.

    Any belt run that long is going to flap quite a bit. I would make sure that your idler arm is free to move and that the spring that tensions it is in the right places. Check the spindles too.

    Could just be bad luck. I had a brand new walkbehind that I engaged the blades on and the belt snapped....very first time the blades were ever run on it.
     

Share This Page