Bought the badboy mz today!

Discussion in 'Homeowner Assistance Forum' started by Pooswa, Mar 9, 2012.

  1. saw n mow

    saw n mow LawnSite Senior Member
    Posts: 273

    No problem. I replied to your PM.

    Kevin
     
  2. Pooswa

    Pooswa LawnSite Member
    Posts: 66

    Now well into second season of grass cutting here..still loving my badboy mz
    No problems so far..

    I haven't regretted this purchase one bit and would do it again...
     
  3. retrodog

    retrodog LawnSite Silver Member
    Posts: 2,420

    Hey man, kandgmowers.com has alot of parts listed...
    Posted via Mobile Device
     
  4. Pooswa

    Pooswa LawnSite Member
    Posts: 66

    Good find retrodog ... Thanks
     
  5. saw n mow

    saw n mow LawnSite Senior Member
    Posts: 273

    Hey Kevin, does Badboy have any plans to put manual foot-assist deck lifts on the CZT or ZT models in the future?

    Kevin
     
  6. retrodog

    retrodog LawnSite Silver Member
    Posts: 2,420

    Only czt, rumor is in september we will start seeing a foot assist pedal of some kind...
    Posted via Mobile Device
     
  7. saw n mow

    saw n mow LawnSite Senior Member
    Posts: 273

    Sounds good!

    Kevin
     
  8. Pooswa

    Pooswa LawnSite Member
    Posts: 66

    There is aloud pitch noise coming from my mower deck ...I assume it's my spindle? If it is the spindle ..is there a way to tell which one is bad?should I just run it till it breaks completely are replace as soon as I can get a part?

    Thanks
     
  9. saw n mow

    saw n mow LawnSite Senior Member
    Posts: 273

    If you're able to safely do so, I would take off the deck belt, raise the front of the mower, and spin each blade by hand and see if you can hear something similar to what you heard with the mower running with the deck engaged.

    Before you do take off that belt, realize that it can be a chore to get it back on. I think there is a diagram on the deck to show you how the deck belt is routed through the pulleys when you go to put the belt back on.

    Kevin (retrodog) will probably see your post and have some better advice.
     
  10. retrodog

    retrodog LawnSite Silver Member
    Posts: 2,420

    Hey take belt off and spin all pulleys you will find the culprit.... prolly an idler, or spindle bearing, lmk i can send u either one...
     

Share This Page