Br 600 locked up

Discussion in 'Mechanic and Repair' started by Nathan 281, May 1, 2008.

  1. Nathan 281

    Nathan 281 LawnSite Member
    from MN
    Posts: 80

    Was working today and ran and started just fine went to start and blow off the drive way and about 5 minutes into the job it stopped hard like something had stuck inside it the engine will spin freely until it gets to the top and then stops I pulled the valve cover apart and the valves are still attached to the springs. Their seems to be no head I can pull off to look inside any ideas is it worth trying to fix about 4 years old now.
     
  2. FIXDISS

    FIXDISS LawnSite Senior Member
    Posts: 445

    Remove spark plug and insert a thin blade screwdriver into the plug hole until you touch the top of the piston. Turn engine slowly while trying to maintain contact with piston. If piston does not move up and down then the rod is broken.
     
  3. Nathan 281

    Nathan 281 LawnSite Member
    from MN
    Posts: 80

    piston moves up and down fine it gets almost to the top and then its like something stops it but the valves are inside the clips
     
  4. rjxj

    rjxj LawnSite Member
    Posts: 80

    Nothing in the starter or fan area? Just wondered before going too far.
     
  5. qps

    qps LawnSite Bronze Member
    from Indy
    Posts: 1,484

    funny..when I was solo I could make a piece of equipment last for at least four or five years, now we go thru at least two trimmers and one or two blowers per season...nitwit employees...sounds like time for a new blower
     
  6. rjxj

    rjxj LawnSite Member
    Posts: 80

    You mean stuff like.......That should be enough oil............it wont hurt it...........well..its not mine.......he has lots of money, hes a business owner...etc. etc.
     
  7. qps

    qps LawnSite Bronze Member
    from Indy
    Posts: 1,484

    You got it...bro..
     

Share This Page