BR600 took a crap today

Discussion in 'Lawn Mowing' started by greengiant9963, Apr 15, 2008.

  1. greengiant9963

    greengiant9963 LawnSite Senior Member
    Posts: 761

    I have had this blower for 3 seasons now and it has really saved me alot of time on cleanups in the spring and fall. Today in the middle of a cleanup the power slowly went on it. Tried starting it back up and nothing. I run 93 high test gas and have never had a problem until today. Always would start on first or second pull. Tons of power also. Took it to my dealer before they closed this afternoon. Not sure what the problem is. I have been looking at adding another backpack for this fall and was going to get another BR600 but not sure now.
     
  2. SimonCX

    SimonCX LawnSite Senior Member
    Posts: 731

    Did you check the gas lines? I had the same thing last month and it was a cracked gas line just above the tank.
     
  3. KGR landscapeing

    KGR landscapeing LawnSite Bronze Member
    Posts: 1,544

    couple things spark arrestor on the muffler? the coils on the 4 mixs r known to go but usally its just one day you go to start it and you pull your arm off.
     
  4. jaybird24

    jaybird24 LawnSite Senior Member
    from midwest
    Posts: 623

    3 yrs on a 4 mix, consider yourself lucky, if we got 2 we were happy. When you buy another try redmax, great blowers.
     
  5. VanceTrendov

    VanceTrendov LawnSite Member
    Posts: 92

    What happens is those black rubber bushings wear out, and then the tank vibrates to much, causing the gas line to crack.

    Watch those bushings
     
  6. kleankutslawn

    kleankutslawn LawnSite Bronze Member
    Posts: 1,185

    wow the dealer may tell you its dead
     
  7. Charles

    Charles Moderator Staff Member
    Posts: 7,952

    Things to check:

    Fuel filter
    Carbon buildup in muffler
    Spark plug
    Leaks
    Blocked fan
     
  8. KGR landscapeing

    KGR landscapeing LawnSite Bronze Member
    Posts: 1,544

    i for got all about the filter. i have gone threw like 2or3 in my one saw. i dno whats going on with that. pull your arm off one day get the pliers pull it off and boom it starts. replace and your good to go
     
  9. SimonCX

    SimonCX LawnSite Senior Member
    Posts: 731

    Not sure if that was what caused it, but it was without those rubber bushings for about 2 years.
     
  10. yungman

    yungman LawnSite Bronze Member
    from Calif.
    Posts: 1,274

    Watch out, you might be misconstrued as bashing 4MIx!!!:laughing::laughing::laughing:
     

Share This Page