Briggs 6 hp running over the rpms

Discussion in 'Mechanic and Repair' started by S man, May 7, 2006.

  1. S man

    S man LawnSite Gold Member
    Posts: 3,562

    I have a murray I found that was submerged during the storm last year. And when I got it running it runs waaaay over the rpms but shows no signs of problems except for the speed. I took it to my neighbor and he fixed the carb and said it was designed to run like that. Is there a way to fix it? And yes I tried the little spring and if you pull it forward or backward it just runs the same.


    Oh and my honda hr214 is in the shop and getting fixed. :)
     
  2. lawnmaniac883

    lawnmaniac883 LawnSite Silver Member
    Posts: 2,613

    Sounds like your governor is not working properly. Remove the shroud from the engine and make sure that the springs and levers are attached and functioning.
     
  3. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    Read the top thread in this forum.
     
  4. S man

    S man LawnSite Gold Member
    Posts: 3,562

    Thank you restorob. What's your take on this? Others have told me not to use it.
     
  5. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    Sorry I'm Not sure what your talking about, I was referring to the thread about posting model and spec. numbers then I can see exactly what engine you need help with.
     
  6. S man

    S man LawnSite Gold Member
    Posts: 3,562

    I'll get the info off the mower tomorrow.
     

Share This Page