Briggs 8 Hp cuts out under load

Discussion in 'Mechanic and Repair' started by 2001john, Sep 30, 2004.

  1. 2001john

    2001john LawnSite Member
    Posts: 23

    Hi There ,
    Got problem with this 8 Hp Briggs Mod 190707 on a ride-on mower that cuts out when the blades are in gear. Otherwise runs fine , Cleaned carby ,I think the govenor arm may be bent or a weak spring . Any idea's guys

    John
     
  2. fixer67

    fixer67 LawnSite Silver Member
    Posts: 2,100

    What do you mean by "cuts out"? Does it just die like you turned the switch off or does it choke out like it is overloaded? Had a man once buy a new carb for a rider that he though was stalling out from a bad carb when he turned on the blades. It turned out to be a bad safety switch on the seat. To see if it is a switch problem killing the engine disconnect the kill wire at the throttle control bracket and see what happens. When you do this you will have to re-connect the wire or unplug the spark plug wire to kill the engine. You would not believe at the number of engine problems people have that turn out to have nothing to do with the engine but is the unit the engine is mounted on. Also make sure the blades turn freely. Have seen frozen spindles cause and engine to stall or even have rags or wire wraped around the blades.
     
  3. allseasonturf

    allseasonturf LawnSite Member
    from ohio
    Posts: 15

    belt drive deck ? and also need type code,,,4 digits after the model #
     
  4. rockytopp

    rockytopp LawnSite Member
    Posts: 120

    You say you cleaned the Carby? sounds as though you did not get the adjustments back as they should be. Might try opening up your high speed a bit at a time.. Float level could be low perhaps.... But I would think just adjustment would cure your problem. If it was running good befor.
     

Share This Page