1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

Briggs and Stratton priming problem

Discussion in 'Mechanic and Repair' started by wil928, Aug 30, 2011.

  1. wil928

    wil928 LawnSite Member
    Posts: 2

    Hi:

    I hope someone can help me. I have a 5 year old 19" push lawn mower (Troybuilt) with a Briggs and Stratton engine (Model series 124T00). I was having trouble staring the mower, so I took apart the primer system. I cleaned out the carburetor, replaced the gas line and the primer bulb. I put everthing back together and the mower still doesn't start. I noticed that the primer was not pulling gas. Under close inspection I realized I did not attach the grommet to the base-air cleaner primer (Part # 792040). I took the carburetor off and attached the grommet correctly. The primer bulb is still not pulling gas into the carburetor. I hear a faulty vacuum somewhere in the carburetor (Part #498170). What did I do wrong??:confused:

    Thx
     
  2. StihlMechanic

    StihlMechanic LawnSite Bronze Member
    Posts: 1,133

    The air filter assembly may be warped. Try pushing it towards the carb and try priming it, if this works replace the part.
     
  3. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024


    Or for less, you can stack three gaskets between the base and carb then snug it back down......
     
  4. wil928

    wil928 LawnSite Member
    Posts: 2

    Thx for the info. I'll give it a shot!
     

Share This Page