Briggs and Stratton won't run correctly

Discussion in 'Mechanic and Repair' started by briggsman65, Sep 5, 2005.

  1. briggsman65

    briggsman65 LawnSite Member
    Posts: 22

    I just acquired a Walmart special mower from a friend of mine. It has 3.5HP B&G motor on it. When I got it it would start but only run for a few seconds about 30 seconds and shut off. If I pushed the primer bulb it would keep running. So I pulled the gas tank and carburetor off. It is a very simple set up. I unscrewed the carburetor off of the gas tank and sprayed it with carburetor cleaner. When I put it all back together same thing. So I took it back apart again this time removing the gaskets and really spraying. Didn't really see any dirt but sprayed anyway. This time when I put it back together it now runs without shutting off. Only one catch it doesn't run correctly. There are no carburetor adjustments like screws or anything. When it runs it runs low and high consistently.........not at one single high rpm like it is supposed to so that you could actually cut grass with it. Is there something else I should check now? I put a new plug in it, new gas, cleaned the flywheel which really wasn't rusty or dirty. The mower is only 3 years old and for the most part in like new condition. Is it still carburetor problems? Air filter is cleaned too. Thanks ahead of time for your help.
     
  2. fixer67

    fixer67 LawnSite Silver Member
    Posts: 2,098

    Post the model , type , code numbers for more help
     
  3. briggsman65

    briggsman65 LawnSite Member
    Posts: 22

    model 90902
    type 2005 B2
    code 00102552
     
  4. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,022

    Something is wrong with these numbers ! There is only one 90902 listed and it has spec. # 3309 and has a old pulsa jet carb. on it, No primer bulb.
    If you do have the plastic carb. which should be on this newer unit make sure the main jet is open and replace the diaphragm.
     
  5. briggsman65

    briggsman65 LawnSite Member
    Posts: 22

    model 90902
    type 2005 B2
    code 00102552


    model # in fact is wrong it should be 9D902

    I guess I should get some glasses...lol
     
  6. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,022

    Ok, Remove reference # 363 screen and make sure it's clean, Then check the main jet under the screen. Then replace ref. # 394 diaphragm. Make sure the air filter is in place when test running, This carb. is a fixed jet style and will not run properly with the air filter off.
    Also check ref. # 612 pick-up tube and make sure that screen is also clean.
    Good luck
     
  7. briggsman65

    briggsman65 LawnSite Member
    Posts: 22

    Did all of that................My neighbor came over and said "hey" I have one of those exact mowers I am using for parts you can have anything you need off of it. After 6 times removing my carburetor I figured what the hey I will try his carburetor. Well if I had to go off of looks of it I would have said no way is it going to work either. When I took his carburetor off it had obvious dirt and deposits on all the screens and things (when I had mine off I saw NO dirt). I cleaned it up and put it on and violla I now have a running mower. Still real curious why the one that was on the mower didn't work. By looks and cleanliness alone it should work. But oh well.........thanks for the help everyone.
     
  8. briggsman65

    briggsman65 LawnSite Member
    Posts: 22

    Did all of that................My neighbor came over and said "hey" I have one of those exact mowers I am using for parts you can have anything you need off of it. After 6 times removing my carburetor I figured what the hey I will try his carburetor. Well if I had to go off of looks of it I would have said no way is it going to work either. When I took his carburetor off it had obvious dirt and deposits on all the screens and things (when I had mine off I saw NO dirt). I cleaned it up and put it on and violla I now have a running mower. Still real curious why the one that was on the mower didn't work. By looks and cleanliness alone it should work. But oh well.........thanks for the help everyone.
     
  9. briggsman65

    briggsman65 LawnSite Member
    Posts: 22

    Did all of that................My neighbor came over and said "hey" I have one of those exact mowers I am using for parts you can have anything you need off of it. After 6 times removing my carburetor I figured what the hey I will try his carburetor. Well if I had to go off of looks of it I would have said no way is it going to work either. When I took his carburetor off it had obvious dirt and deposits on all the screens and things (when I had mine off I saw NO dirt). I cleaned it up and put it on and violla I now have a running mower. Still real curious why the one that was on the mower didn't work. By looks and cleanliness alone it should work. But oh well.........thanks for the help everyone.
     
  10. briggsman65

    briggsman65 LawnSite Member
    Posts: 22

    Wow I am having all kinds of good luck.................my message posted 3 times.
     

Share This Page