Briggs fuel pump problems

Discussion in 'Mechanic and Repair' started by bbahun, Jun 14, 2006.

  1. bbahun

    bbahun LawnSite Member
    Posts: 31

    Took the carb apart to clean it on a 18.5 hp briggs & stratton Model 42A707. I put new springs and diaphram in the fuel pump, cleaned the float, needle, bowl and fuel passages with carb cleaner. I can't get the bowl to refil with fuel. If I refill it and put the carb back together it will run until it is empty. I can't figure out why it will not pull any fuel into the carb bowl. Any suggestions?:)
     
  2. lawnmaniac883

    lawnmaniac883 LawnSite Silver Member
    Posts: 2,613

    Did you put the diagraphm in backwards? Is the fuel valve turned on? Start with common sense stuff first.
     
  3. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    If you didn't get the two hoses mixed up you need to take the fuel pump back apart and make sure you got all three springs in the right place and the two small brass ones didn't move out of place while assembling.
     
  4. fixer67

    fixer67 LawnSite Silver Member
    Posts: 2,100

    I always put a dab of grease on the small brass springs to hold them in place. Not much grease, just enough to "glue" them in place.
     
  5. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023


    Ditto, Same here.
     
  6. bbahun

    bbahun LawnSite Member
    Posts: 31

    Thanks guys! I tried the grease and it worked. Running great. Thanks for the help.
     

Share This Page