Broken rocker arm stud on kaw 17 hp

Discussion in 'Mechanic and Repair' started by roket77, Jul 24, 2008.

  1. roket77

    roket77 LawnSite Member
    Posts: 44

    I have broken the same rocker arm stud(stud that holds rocker arm in place) 3 times in the last 3 days,,all on the same side(left) of my fh 500v 17 HP kaw engine,,obviously something is causing this,,is this something i can fix,?,,is it worth fixing?,,thanks for any suggestions
     
  2. B&A lawn care

    B&A lawn care LawnSite Member
    Posts: 70

    I dont know about the Kaw but on a Kohler twin the hydraulic lifters can pump up when there is a failure like that. Then when you replace the broken part the pumped up lifter pushes things past where they like to be and breaks things again. Ask me how I know this??:hammerhead: On the kohler you can assemble and let it sit before turning over hoping the lifter will colapse back or remove the lifter, dissasemble it and dump the oil.
     
  3. BigFish

    BigFish LawnSite Gold Member
    Posts: 3,364

    That eng. has solid tappets. You need to pull the head and take a CLOSE look! Could be a broke spring, seal, sumpin' in the cyl........
     
  4. sawman65

    sawman65 LawnSite Senior Member
    Posts: 751

    they are real bad for the valves sticking. i bet its the intake stud right?
     
  5. Sharpcut 1

    Sharpcut 1 LawnSite Senior Member
    Posts: 450

    I've had a couple of Kawi heads, the guide comes dislodged from the head and bends the pushrod/and or breaks the stud.
     
  6. swandrie

    swandrie LawnSite Member
    Posts: 41

    same old thing for my 17hp kaw!!! looks like its an issue??? didn't have time to fix so got a new one! hope this one holds up!
     

Share This Page