Carb Problems

Discussion in 'Mechanic and Repair' started by burlap, Sep 12, 2006.

  1. burlap

    burlap LawnSite Member
    from Indiana
    Posts: 66

    17 hp kawasaki JD F525
    Problem: Won't start w/o a prime in air cleaner or unless it's just been running.
    Pumping gas at carb.
    Solenoid works from battery and I can feel it click when I turn the key.
    I ran a wire through the main nozzle and the intake nozzle-needle orfice.
    What else should I check?
     
  2. fly-4-fun

    fly-4-fun LawnSite Member
    Posts: 0

    Be sure that the choke butterfly is closing all the way in the throat of the carb.They sometimes get to where they are not all the way shut when the control cable is set to "Choke".
     
  3. lawnmaniac883

    lawnmaniac883 LawnSite Silver Member
    Posts: 2,613

    If you have cleaned the carb fully then it will start with a gas prime and run once started?

    Check your carb vent, should come out of the top may have a length of plastic tubing on it. Have you adjusted your valves? How many hours on the unit?
     
  4. burlap

    burlap LawnSite Member
    from Indiana
    Posts: 66

    I did check the choke and it looked closed to me.
    I'm rebuilding this from several mowers so there is some time on the unit and the carb. The valves were adjusted. It seemed to idle good when it was running. I will check the vent tomorrow. Would the vent work okay once it's going but be a problem while starting? Thanks again.
     
  5. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    Not likely.....It would be the opposite You need to make sure the choke is closing ALL the way as stated already.
     

Share This Page