Carb. Problems???

Discussion in 'Mechanic and Repair' started by dago52, Apr 23, 2008.

  1. dago52

    dago52 LawnSite Member
    Posts: 249

    I have a 16hp briggs vangaurd on my Areins ztr. The mower was donated so I had to bring it back to life. I got it running, but I have to use starting fluid to start it for the first time. After it gets warmed up and try to recrank it, I still have to pull the choke to get it running. I only have to use the starting fluid if it sits up over night or when it is cold. I also put some seafoam in the carb., but that did not seem to help. I am thinking about pulling the carb., but want to make sure before I tear it down.


    Thanks
     
  2. dago52

    dago52 LawnSite Member
    Posts: 249

    Anyone have any info???
     
  3. LarryF

    LarryF LawnSite Bronze Member
    Posts: 1,171

    You know what to do. Do it!
     
  4. Bill Kapaun

    Bill Kapaun LawnSite Senior Member
    Posts: 923

    IF this engine has a fuel pump, maybe the line is allowing the fuel to run back to the tank?

    IF that carb has a drain screw, you might check it before you start to make sure there is fuel in the carb.
    Also, mak sure the choke is being FULLY applied. Sometimes a cable can slip in the clamp.
     
  5. dago52

    dago52 LawnSite Member
    Posts: 249

    I don't know what to do or I would have done it. I am thinking its a carb. problem, but just wanted some verification. I sometimes when you get into some old equipment things can get worse. I just need one season out of ths mower until I can get a new one.

    I will check the carb. bowl for fuel and change the fuel filter while I am there. I checked the choke and it is closing all the way.

    Thanks for the input
     

Share This Page