charge pump kubota

Discussion in 'Mechanic and Repair' started by grass disaster, Jun 29, 2007.

  1. grass disaster

    grass disaster LawnSite Silver Member
    Posts: 2,578

    well the kubota's not runnign so good.

    the pto is shutting off when i raise the deck. also deck is slow to raise.

    dealer told me, hopfully that's all thats wrong with it is the charge pump which is located on the front of the tranny.

    it is driving fine.

    can anyone add anything to this. or anyone else have similar problems?
     
  2. grass disaster

    grass disaster LawnSite Silver Member
    Posts: 2,578

    anyone else having problems with the charge pump?
     
  3. grass disaster

    grass disaster LawnSite Silver Member
    Posts: 2,578

    i must be the only one that's ever had a problem with this.

    i hope it's only the pump that is bad. the pump is only like $100.

    if i have to but the whole plate it's like $1600.
     
  4. DiyDave

    DiyDave LawnSite Bronze Member
    Posts: 1,695

    sooner or later someone with the same problem will read your post. Check back in a couple of days:cool2: :waving: :waving:
     
  5. grass disaster

    grass disaster LawnSite Silver Member
    Posts: 2,578

    yeah i'm still:cry: waiting
     
  6. grass disaster

    grass disaster LawnSite Silver Member
    Posts: 2,578

    bump.


    i would really like to see if anyone knows anything about this before i start tearing stuff apart.


    the dealer doesn't want to order me any parts till i take off the charge pump and see if i can see what's wrong.

    is it the charge pump? the plate that it butts up against? or a sticky valve or something?
     
  7. grass disaster

    grass disaster LawnSite Silver Member
    Posts: 2,578

    ahh hello?


    does the charge pump drive the hydros?



    because it seems to be griving fine.
     
  8. themowerman

    themowerman LawnSite Senior Member
    from NJ
    Posts: 297

    Your dealer should be able to plumb in gauges to read the health of your pump. A gauge test will tell if it is the charge pump or not. The only other way is to inspect it.....maybe you sheared the pump pin.....
     
  9. razor1

    razor1 LawnSite Bronze Member
    Posts: 1,985

    I had a a similar problem with my ZD 21. What year and model Kubota do you have?
     
  10. grass disaster

    grass disaster LawnSite Silver Member
    Posts: 2,578


    zd18 2002 almost 800 hrs.

    the zd18 and zd21 use the same hydro system.

    what were your symptoms and what was the problem.
     

Share This Page