Charging system help

Discussion in 'Mechanic and Repair' started by jrs76, Mar 3, 2012.

  1. jrs76

    jrs76 LawnSite Member
    Posts: 4

    I have a 5-7 yr rider with a 17.5 B&S. Last season I replaced the battery in the mower, started and ran fine, after a couple hours of use the battery was dead again when I went to start it again (Just jumped it the rest of the season). So obviously there is a charging problem. I have checked the wiring (ground, fuses) and no obvious damage. Now I'm thinking the diode or stator. What is the best way to proceed with diagnosing my issue. It has two wires coming from the stator with an in-line diode above a two-pole connector.
    Any help would be appreciated.
     
  2. T-Trim

    T-Trim LawnSite Member
    Posts: 204

    Well first get a wiring diagram of the mower and the engine. That helps out a lot of times. I really can't help you out anymore. Other then looking for any broken, disconnected, or two wires touching and shorting out.
     
  3. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,022

    Disconnect the stator from the tractor harness, Set a multimeter to DC volts scale, Hook the black test lead to any good ground and the red to the stator wire with the diode. Start the engine and give it full throttle then read voltage out-put.

    Engine model AND type numbers along with color of stator wires AND plastic connector plug would be helpful.

    Tractor brand and model numbers could be handy as well....

    http://www.lawnsite.com/showthread.php?t=144040
     
  4. jsslawncare

    jsslawncare LawnSite Bronze Member
    Posts: 1,674

    I had a friend, on his the electric clutch was bad. Caused to much of a drain.
     
  5. jrs76

    jrs76 LawnSite Member
    Posts: 4

    I checked the DC volts off the stator...18 after the diode.
    The engine info is:
    B&S 17.5 I/C OHV
    model 31c707-0603 e1

    Sorry I don't have the mower model info....my computer is at a different place than the mower. It is a Troybilt with "Pony" on the side. 42" deck.

    It has two wires total off the stator
    one red with the diode
    and one black

    I also checked the battery
    12.5 not running
    started and full throttle gradually climbed from 12.5 to 16 before I shut it off as this seemed really high?
    Could it be over-charging and boiling the battery and that is what is causing the batteries to fail? If so what is the fix?
     
  6. jrs76

    jrs76 LawnSite Member
    Posts: 4

  7. jrs76

    jrs76 LawnSite Member
    Posts: 4

    I will check the lawn mower out tomorrow b/c I didn't really see any electrical at all in the parts diagrams.
    Posted via Mobile Device
     
  8. BigFish

    BigFish LawnSite Gold Member
    Posts: 3,364

Share This Page