cleaning trimmer carb.

Discussion in 'Lawn Mowing' started by Nitroman, Mar 19, 2004.

  1. Nitroman

    Nitroman LawnSite Member
    from indiana
    Posts: 217

    I've Never done this, I have a echo 210 and it runs a little ruff. When I start it.. it bogs down, it takes at least three times of starting it to get it to stay running. Unless I just flore the gas on the second or third time it trys to start after pulling it 15+ times. Then after a few minutes of running high rpms it fine. :confused:

    When you clean the air filter what do you guys do? Use water, blow it out or just replace it. It's only been threw one season.

    Any tips on cleaning the Carb?:(
     
  2. tailoredlook

    tailoredlook LawnSite Member
    Posts: 142

    Try some carb cleaner. Available at any auto parts store.
     
  3. GreenTurf

    GreenTurf LawnSite Member
    from NJ
    Posts: 41

    i think to seem this is the way echo's are. all mine do it even when they are brand new. when you get it started toggle the choke lever up and down when you have it at 1/2 to 3/4 speed and should keep it running. I do that all the time.
     
  4. Lawn-N-Garden Guy

    Lawn-N-Garden Guy LawnSite Senior Member
    Posts: 321

    Did you change the plug ?I usually tear mine totally apart and clean everything.If exhaust is gunked up I tear it off and dump a little gas in it and ignite it (Outside of course) and let it burn out. The little spark arrester on my Echo Hedge shears plugged up and it would run right.I like to freshen up my stuff every pre-spring that way alot of breakdowns are eliminated.
     
  5. Lawn-N-Garden Guy

    Lawn-N-Garden Guy LawnSite Senior Member
    Posts: 321

    I soak my filters overnite in dish liquid and water,Blow them out with compressed air then let dry out, Check over pre-cleaners and replace if tore.I spray them with a little air cleaner oil for foam filters.
     
  6. Westbrooklawn

    Westbrooklawn LawnSite Senior Member
    Posts: 417

    I have had terible experience with the gas lines on echo two cycle equipment. They break down.....due to the poor quality of today's gas according to my echo dealer. They don't look bad on the outside, but replacing them works wonders in the way the equipment runs. I gues they develop air leaks which messes up the way the fuel feeds to the carb.

    I have had trimmers that don't run right......cleaned exhaust, cleaned carb, changed plugs, adjusted carb, etc. but they still didn't run right. Changed gas and vent lines and they straightened right out. Try it.....
     
  7. competitiveimageland

    competitiveimageland LawnSite Member
    Posts: 192

    sounds like a typical echo to me
     
  8. Curtis

    Curtis LawnSite Member
    Posts: 162

    Take the exhaust screen out and throw it away those things have caused me more trouble than their worth . Also clean the exhaust port but make sure the piston is closed .
     
  9. ceytl

    ceytl LawnSite Member
    from SLC, UT
    Posts: 12

    I cannot believe that quality of expertise in this area. I am saying this sarcastically. First of all never take off the exhaust screen; doing so will cause internal engines problems down the road. The exhaust should be cleaned or replaced when there is too much carbon build up. To clean the best way is carb cleaner or a good solvent. I always put new screen in because it is not that expensive.
    The best way to clean your carb is with carb cleaner; however, this will not always work, you may need to buy a carb kit which can cost between 10-15 dollars. Sometimes it is easier to buy a whole new carb for $35. Always replace your spark plug, bad gas or poor fuel mixture can foul the plug.
    On the Echo's they are known for carb problems. They use Zama carbs the same that Ryobi, Homelite and WeedEater.
    If it takes you more than an hour to fix your carb problems it would be cheaper for you to take it somewhere to fix it.
    Your time is worth money.
     
  10. bugspit

    bugspit LawnSite Senior Member
    Posts: 769

    Is there something better than Echo? Don't all 2-strokes have these issues?
     

Share This Page