Completely Noob Grease Gun Question

Discussion in 'Mechanic and Repair' started by greenred, Jun 8, 2008.

  1. greenred

    greenred LawnSite Senior Member
    from IL
    Posts: 916

    It has been some time since I have had to change the grease cartridge in my grease gun and after replacing my old one I can not get the gun to work.

    I opened the gun up and took out the old one and pulled the spring and plunger in the base back and locked it in position. I then inserted the new cartridge, and released the mechanism that pulls the spring and plunger at the base of the gun. How ever I can not get the gun to pump grease. I also can not get the bar that pulls the spring and plunger back to pull them back. It just moves back and forth freely - while the spring stays extended. No matter how much I pump I cant seem to generate any internal pressure in the gun.

    Like I said its been a long time since I had to do this and I can not figure out what I am doing wrong. Worse part is 5 minutes of messing with it and you can not do a damned thing cause your hands are to slippery from the dammed grease.
     
  2. Stillwater

    Stillwater LawnSite Platinum Member
    Posts: 4,837




    around near the plunger their should be what looks like a screw, that is a bleeder, to bleed out the air pocket that is causeing the prob.
     
  3. greenred

    greenred LawnSite Senior Member
    from IL
    Posts: 916

    Thank you for the advice I will give it a try.
     
  4. lubricity

    lubricity LawnSite Member
    Posts: 125

    Did you put the tube in the right end? If you put the tube in the plunger end, the plunger will not pass the metal ring on the end of the tube.
     

Share This Page