Craftsman 22hp riding mower - won't start

Discussion in 'Mechanic and Repair' started by Belleaire Care, Apr 25, 2012.

  1. Belleaire Care

    Belleaire Care LawnSite Member
    Posts: 27

    Hi everyone!
    Would someone be able to help me with this 'no start' problem, please?
    I mowed with this Craftsman (model 944.606941) last Sunday. It ran and cut well.

    I got it home and it wouldn't start when I tried to get it off the back of the truck.
    Once in my garage, I put a new solenoid on but still nothing!
    I took the hood off of it and turned the key and heard a slight 'click' right at the base of the carburator.... where the white/grey wire plugs in to the brass base of the carb.

    I followed this wire back to where it joins other wires at the other end of the motor. The wire appears good and connections are good.

    Gotta get this mower working! Any help would be greatly appreciated!!

    Thanks,
    Mike
     
  2. weeze

    weeze LawnSite Fanatic
    Posts: 8,157

    starter? battery?
     
  3. Belleaire Care

    Belleaire Care LawnSite Member
    Posts: 27

    Hi there!
    No, the battery and starter both seem good.
    When I turn the key there is just that slight click from the base of the carb.
    When I pull the grey wire from the base of the carb there is no more 'click'.... there is no sound at all when I turn the key.
     
  4. weeze

    weeze LawnSite Fanatic
    Posts: 8,157

    motor should turn over. if not there's a dead battery or a dead starter.
     
  5. Belleaire Care

    Belleaire Care LawnSite Member
    Posts: 27

    Hi Jason,

    Thank you..... I am going to check the battery again right now... I thought it was good but now that I think of it.... I did have to boost it a few times at the beginning of this season.

    Thank you again and I'm gonna check it out right now!

    All the best,
    Mike
     
  6. Belleaire Care

    Belleaire Care LawnSite Member
    Posts: 27

    Don't think it's the battery... The tractor will start when on battery charger and I cross the poles on the solenoid with a screwdriver.

    Maybe like you said Jason... The starter.
    Posted via Mobile Device
     
  7. unit28

    unit28 LawnSite Bronze Member
    Posts: 1,557

    if it clicks it has juice.
    parking brake on // seat switch conected
    v/ohm test the battery

    But....
    sounds like bad connection @ solenoid
    if it clicks everytime- with a definate loud fast click as soon as you bump key
     
  8. Belleaire Care

    Belleaire Care LawnSite Member
    Posts: 27

    Hey Unit 28!
    Thank you for the info!
    It is not a loud click from the fuel solenoid but just a slight click.
    When I cross the poles on the solenoid it wil still only start when it is being charged or 'boosted'.

    It will turn over weakly when I cross the poles without boost.
    Posted via Mobile Device
     
  9. cfranzen

    cfranzen LawnSite Member
    Posts: 27

    Had a similar issue with my craftsman tractor last year. It was the battery, clicked but wouldn't start. Worked fine when I used it to plow the drive in the winter and in the spring it was done. Wouldn't take much of a charge. Grabbed a new battery and good to go. Good luck.
     
  10. Belleaire Care

    Belleaire Care LawnSite Member
    Posts: 27

    Hi there C Franzen,
    Thank you for the info.

    I thought so too... Just came back from store and put a née battery on.

    Nothing.. Just the little click from fuel solenoid.

    I tapped the fuel solenoid and now nothing at all :(
    Posted via Mobile Device
     

Share This Page