Craftsman Rider Mower

Discussion in 'Mechanic and Repair' started by sbcboy1, Jul 24, 2008.

  1. sbcboy1

    sbcboy1 LawnSite Member
    Posts: 13

    I have a craftsman ride on lawn mower. The problem im having with the mower is when its cold it runs fine but when i start to mow after about 10-15 minutes when its hot the engine is surgeing and when it dose that i cant mow. Dose anyone have any idea what this could be?
     
  2. Fisher40037

    Fisher40037 LawnSite Member
    Posts: 36

    It could be a fuel related issue, or just a valve adjustment problem, but we need to know what you have, please post some model numbers off of the
    engine.


    Fish
     
  3. sbcboy1

    sbcboy1 LawnSite Member
    Posts: 13

    The engine is a B&S Twin 21. I have had this thing in three shops and 500.00 later i still have the same problem.
     
  4. All_Toro_4ME

    All_Toro_4ME LawnSite Bronze Member
    Posts: 1,578

    does it sound like its cutting in and out, or like a sputtering sound? Like RPMs go to normal, then lower, then normal etc?
     
  5. sbcboy1

    sbcboy1 LawnSite Member
    Posts: 13

    At full speed it sounds like it is going down then going up and you cant cut at all.
     
  6. sbcboy1

    sbcboy1 LawnSite Member
    Posts: 13

    I also have a toro mower if you can help with that to? It wont start from key but if you jump the solinoid the engine spins but no spark.
     
  7. GravelyNut

    GravelyNut LawnSite Bronze Member
    Posts: 1,594

    There are a number of things that can cause those problems. Fuel, valve adjustment, or coil breakdown. With fuel, it could be a bad pump, a carb float or needle getting stuck, crud clogging a jet, collapsing fuel line, bad fuel filter, or a hose routed too close to a heat source. Or even something as simple as a bad gasket between the carb and the block.
     

Share This Page