1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Craftsman riding mower transaxle

Discussion in 'Mechanic and Repair' started by lgunner, Jun 17, 2006.

  1. lgunner

    lgunner LawnSite Member
    Posts: 1

    A week ago I brought my riding mower in to have work done on engine.The engine was removed and repaired. the mechanic put everything back together and now he tells me the transmission is locked up. The transmission was working find when i brought it in. Could he have done something wrong when he put everthing back together. A new transmission is very expensive. The transmission is a hydrogear mdl# 322-0510(171613). Can someone please help me on what to check or do.You can email me: lgunnerj@yahoo.com. Thanking you in advance.

    FIXDISS LawnSite Senior Member
    Posts: 445

    Please post model #s,mower brand etc. Maybe he has belt routed incorrectly. With above #'s I'm sure someone here can get you a diagram to check belt alignment. BTW does the pump turn freely when clutch/brake is in park position ? Could be belt is installed around a belt guide instead of inside as it should be or the pulley on crankshaft is not properly lined up.Hopefully this gives you a place to start. :dizzy:
  3. khouse

    khouse LawnSite Bronze Member
    Posts: 1,465

    he may have opened the dump valve to push the mower around. make sure it's in operating position.

Share This Page