Cutting Problems with Ferris 1500 *PICTURES*

Discussion in 'Mechanic and Repair' started by jtruck618, Apr 30, 2012.

  1. jtruck618

    jtruck618 LawnSite Member
    Posts: 189

    Here are some pics of a yard I cut with my Ferris 1500. Having problems with it's cut. Cuts some places really well, others not so much. I adjusted the rear shocks to the highest setting, thinking the suspension was the problem. Deck is level, checked it several times. Been to the dealer twice. I can't figure this out. In thick grass it is most noticeable. Mowing slow, fast or at different angles doesn't change anything. This is an area over my septic laterals.

    [​IMG]

    [​IMG][/IMG]
     
    Last edited: Apr 30, 2012
  2. MSTmarc

    MSTmarc LawnSite Member
    Posts: 27

    Deck not level or bent blade
     
  3. jtruck618

    jtruck618 LawnSite Member
    Posts: 189

  4. jtruck618

    jtruck618 LawnSite Member
    Posts: 189

    I would think bent blade or unlevel deck too. But it's not. I've checked the deck numerous times and the blades are like new. You can see in some of the pics that the area of my yard which is not thick the mower cuts great. I just fertilized last week so soon the whole yard will be thickened up.
     
  5. pugs

    pugs LawnSite Gold Member
    Posts: 3,018

    Refresh my memory. What size deck is it? Is it an ICD deck? Are you using Ferris blades for the ICD deck(have you checked)? Some sizes got out of the factory with the wrong blades on them. If its an ICD deck, do you have it set with no pitch? ICD decks are supposed to be level front to back instead of pitched down in the front like most. Also ICD decks take their own blades and using the wrong blades can cause problems.
     
  6. jtruck618

    jtruck618 LawnSite Member
    Posts: 189


    Yes, ICD deck, 52in, not sure about the blades. The deck is pitched a bit. Not heard that about the ICD deck before. It did this when level too.
    Posted via Mobile Device
     
  7. jtruck618

    jtruck618 LawnSite Member
    Posts: 189

    Anyone else?
    Posted via Mobile Device
     
  8. herler

    herler LawnSite Fanatic
    Posts: 5,145

    Shoot it looks all right to me but check the air pressure in all the tires.
     
  9. fixer67

    fixer67 LawnSite Silver Member
    Posts: 2,104

    Sounds like the clutch or belt may be slipping.
     
  10. jtruck618

    jtruck618 LawnSite Member
    Posts: 189



    Would I hear either of these? Need to find out how to check on these. I guess you think when it gets in tall, thick grass it is put under a load and the belt slips?

    I'm about fed up with this mower.
     

Share This Page