Deck Drive Belt slipping??

Discussion in 'Lawn Mowing' started by AuburnGuy, Jul 17, 2003.

  1. AuburnGuy

    AuburnGuy LawnSite Senior Member
    Posts: 279

    I have a 15hp Toro WB (Proline 37 Recycler Deck). The problem is when the grass is slightly thick (I'm talking about bermuda cut every 5 days) the deck will make loud noises and you can smell the deck drive belt burning and moving a lot more than normal. I have to dis-engage the blade and start back going slow. The belt is not torn and looks okay. Should i replace it anyway? Have any of you had similar problems?

    Thanks Guys.
  2. tiedeman

    tiedeman LawnSite Fanatic
    from earth
    Posts: 8,745

    is the belt maybe too tight, is the belt new, is the mower new?
  3. MacLawnCo

    MacLawnCo LawnSite Bronze Member
    Posts: 1,847

    i would immagine that the deck belt is actually too loose. Tighten it up some. mine was too loose once and it actually started making the belt engagement sounds.
  4. brucec32

    brucec32 LawnSite Platinum Member
    Posts: 4,403

    It's been a while, but I have had one of these mowers. It didn't cut heavy stuff well at all, I recall. But check to make sure your belt tension is correct. It's been so long I can't remember, but I think it could be that your belt tension idler needs greasing, or even the spring needs replacing. But any belt driven deck will burn a belt if you push it too hard. I even broke one about 10 years ago.
  5. AuburnGuy

    AuburnGuy LawnSite Senior Member
    Posts: 279

    Thanks Guys for the advice. I will try to tighten it up first and go from there. I bought new belts anyway, but i think they will be spares. The current belts look fine. Thanks again.

Share This Page