Deere z915b

Discussion in 'Lawn Mowing Equipment' started by beatsworking, Apr 29, 2013.

  1. ProStreetCamaro

    ProStreetCamaro LawnSite Platinum Member
    Posts: 4,133

    Maybe my jd dealer has no clue how to adjust the governor properly or something. I really dont know. I know I ran both mowers the same as I do my own machines and both would loose rpm and start slowing down going up inclines. I have the same 25hp kohler on our 160Z and that mower only has 10cc hydro pumps and motors but inclines or deep grass doesnt even phase it. The 31hp on our 460 is just ridiculous. I wish I had gotten the 29hp efi kohler instead.


     
  2. Ridin' Green

    Ridin' Green LawnSite Fanatic
    Male, from Michigan
    Posts: 13,860

    Is it still really sucking down fuel, or has it at least gotten a little better? When the time comes for me to buy a new Z, it'll be the 460, but it'll have the same engine I have now- FX850 or an efi/dfi version of it. I know Kawi is making it in DFI right now, but I think EFI would be better.
     
  3. ProStreetCamaro

    ProStreetCamaro LawnSite Platinum Member
    Posts: 4,133


    It drinks gas like its going out of style.
    Posted via Mobile Device
     
  4. beatsworking

    beatsworking LawnSite Senior Member
    from MD
    Posts: 276

    originally i was pretty set on a 160, but my gravely dealer has not treated me well with parts/service. Also the deere is a much more solid machine. In person you can really see how the deere is in a different class, it looks twice as big. So far ive only heard 2 people say the 710/915b is underpowered and 10-20 people say it has plenty
     
  5. beatsworking

    beatsworking LawnSite Senior Member
    from MD
    Posts: 276

    Also got a new quote today, $6999 no sales tax sounds like i'll be getting one in the next few weeks unless the engine is down on power
     
  6. weeze

    weeze LawnSite Fanatic
    Posts: 8,590

    i ran a z925m 24.6hp kohler efi for about a week as a loaner mower. it had a 54" deck.

    it ran really smooth. it still had the same problem as mine did when i ran factory blades. it does fine until you hit the thick wet stuff then it bogs down pretty bad. i'm talking about 2 weeks of spring growth weeds and all. during normal conditions it's fine.

    putting G6 blades on the deere makes it a completely different machine. i keep telling people this. i can mow through anything since i change to the G6 blades a year or so ago without bogging down.

    i'm sure people running the larger engine deeres don't have this issue at all but if you are running an engine 27hp or less then i would say it is absolutely necessary to run G6 blades and not use the factory high lift blades.

    the factory blades work fine until you hit the thick/wet stuff and then they just bog the engine down really bad. the G6 blades cure this problem. they put less drag on the engine.
     

Share This Page