did i miss something?

Discussion in 'Hustler Turf Equip (Archived)' started by nmurph, Dec 16, 2005.

  1. nmurph

    nmurph LawnSite Senior Member
    from ga
    Posts: 668

    did you have a fire at HQ?
    also, where are the pics for the blade. i do not see a lin
     
  2. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

    Yes we did.
    Here is the official statement.....

    At 8:15 pm on Monday, December 12, Excel Industries, Inc., manufacturer of Hustler Turf Equipment,
    suffered a significant fire to the Plant 1 production facility. Although the fire was quickly extinguished, there
    was considerable damage to the main power distribution system causing a loss of electricity to the main
    manufacturing facility, computer systems, and administrative offices. Plants 2, 3, and 4 were undamaged
    other than computer and telephone service.
    As of noon on Wednesday, December 14, we had restored telephone, email, and internet service. By
    Thursday afternoon all office areas and functions were on fully-restored power. Parts and wholegoods are
    being shipped. Sales, accounting, and customer service departments are functioning again. Dealers and
    distributors will be unaffected at this point.
    We still do not know how long it will take to restore full electrical service. We are optimistic that we will be
    in full production on January 2, 2006, when we return from Christmas break.
     
  3. mowerconsultant

    mowerconsultant LawnSite Fanatic
    Male, from Syracuse, NY
    Posts: 9,761

Share This Page