Did somebody recently have a brand new RM remote not work?

Discussion in 'Irrigation' started by FIMCO-MEISTER, Mar 8, 2009.

  1. Using my brand new RM remote and it was doing fine then just quit working. Made all the right sounds but the zones wouldn't fire. Checked the controller and all okay there. Seems like we had a recent thread on the same issue.
     
  2. HokieAg07

    HokieAg07 LawnSite Senior Member
    Posts: 352

    I had one doing that, seemed to be some sort of range issue. Sent it back and had it fixed although mine wasnt brand new....
     
  3. DanaMac

    DanaMac LawnSite Fanatic
    Posts: 13,156

    I now TomTom had an issue with the used one he bought. Made all the right noises as well. Needed a new cable going between the two receiver units.
     
  4. I guess I'll try a new battery first. What a bummer. I did show off my new Aquaterr to Henry.
     
  5. EagleLandscape

    EagleLandscape LawnSite Platinum Member
    Male, from Garland, Texas
    Posts: 4,347

    YOU DIDNT SHOW IT ME!

    ...offended...:)
     
  6. EagleLandscape

    EagleLandscape LawnSite Platinum Member
    Male, from Garland, Texas
    Posts: 4,347

    Peter, how much is a new RM?
     
  7. I think 1200-1300. I got a good deal on my new one due to supply house loyalty and pigtail issues, but if it doesn't work new out of the box it costs too much. I've never had an issue like this and I've bought five or so new that I can recall. I did have an issue when they changed the keypad but they got that corrected. I wish though there was a real competitor to RM. Like ARVADA is to GREENLEE's 521. I don't consider TRC a competitor myself. I wish TRC would hire me to make some minor modifications to their sales strategy and remote capabilities. HINT HINT
     
  8. Tom Tom

    Tom Tom LawnSite Bronze Member
    Posts: 1,278

    Yup, thats what happened.

    I checked the continuity of all 9 pins in the cable and one did not work.

    New cable fixed it!
     

Share This Page