Do I need a new transformer?

Discussion in 'Landscape Lighting' started by Mrsamman, Aug 27, 2007.

  1. Mrsamman

    Mrsamman LawnSite Member
    Posts: 30

    I have a 10 year old 300 watt Vista transformer. It has been installed in my current application for about 4 months. It now makes the light blink periodically, It says its the thermal protector but I only have 260 watts on two runs of 50 to 60 ft each.
    Thanks for your responses and patience.
    Scott
     
  2. JackTorsed

    JackTorsed LawnSite Member
    from Utah
    Posts: 57

    It says its the thermal protector

    Who or what is it?

    Is it one of those black units with the flip top and the small white european terminals on the bottom exposed to the open ground. if so it's probably your terminal block that's rotting apart. Does it have a white push button (thermal) or a switch (magnetic breaker) for the low voltage protection?
     
  3. NightScenes

    NightScenes LawnSite Silver Member
    Posts: 2,207

    Remember, wire has a load as well. You might want to cut back a little more on your load. How much is on each home run?
     
  4. ar-t

    ar-t LawnSite Member
    Posts: 49

    1.) I would not run a transformer over 80% of rated capacity. Just because it can supply more is not a good reason to do so.

    2.) None of the Vista transformers that I have used have an blinking light indication of thermal overload. They just have a circuit breaker ("white switch") on the LV side.

    3.) Have you measured the current draw on either the input or output? And the input voltage, to get an accurate VA load?
     
  5. Mrsamman

    Mrsamman LawnSite Member
    Posts: 30

    Jack,
    Yes it has those small blocks and the small white push button circuit breaker, but it never pops, the lights just flicker. I have 90 watts on one block and 170 watts on the other, Last night disconnected two 20 watts and that stopped it. Why after 4 months would it start acting up, I do realize its 10 yrs old. Should I get it looked at and fixed or buy a new one?
    Thanks
    Scott
     
  6. TXNSLighting

    TXNSLighting LawnSite Fanatic
    from DFW, TX
    Posts: 6,462

    get a 600.
     
  7. Pro-Scapes

    Pro-Scapes LawnSite Platinum Member
    Posts: 4,181

    Buy new and be done with it. Just get a quality 600 unit so your not over loaded and you can also add a few lights. Sounds like you have some corrosion or other issues (load is borderline) causing the thermal breaker to open and close when it gets hot. Gets hot lights cut out... cools off lights cut on.

    You reduced load and its ok... its not overheating so either locate the bad connection and or remove some lights from the system or its tranny time.
     
  8. Mrsamman

    Mrsamman LawnSite Member
    Posts: 30

    Anyone have a used 600 watt they want to sell?
     
  9. David Gretzmier

    David Gretzmier LawnSite Gold Member
    Posts: 3,645

    hmm... I don't know if we can sell on this site or not, I'm one state over...
     
  10. Pro-Scapes

    Pro-Scapes LawnSite Platinum Member
    Posts: 4,181

    If you email me I might be able to point you in the right direction. I can list one on ebay for ya... click on my site below and email me and I will set it up
     

Share This Page