Dump bed not working properly, need some advice.

Discussion in 'Trucks and Trailers' started by f50lvr2, Jan 12, 2012.

  1. f50lvr2

    f50lvr2 LawnSite Senior Member
    Posts: 277

    Hi guys, hope everybody's winter is going well. Earlier this year my dump bed on the NPR stopped working correctly. It won't go up or down by just pressing the buttons on the remote. If I run a wire from the battery to the solenoid the motor will start running and I can control the motion, up or down, with the remote. As long as that wire is connected the motor will run. It's not a huge deal to work around but it's still not right. I've been getting it ready to sell recently and this is the only flaw in the vehicle.

    My local Isuzu shop wants around $400 just to look at it, so that's not really an option. BTW, I replaced the solenoid and no change.

    Also, I'll get some pics up if anybody is interested, it's a loaded 2007 NPR HD, 5.2L diesel, automatic, air, PW, PL, cruise, roof vent, etc. with an 12x8x4 dump body on it with removable sides. I'll probably be asking around $26K and it has 38k miles.
     
  2. Jason Rose

    Jason Rose LawnSite Fanatic
    Posts: 5,858

    It's an electric motor type hoist? take it to a hydraulic shop who installs them, they could probably troubleshoot it a LOT cheaper than $400. I was going to guess solenoid myself... B&B hydraulics here in hutch is where I get parts/repairs on mine.

    Wish I had the funds, sounds like a nice truck and is the size I'm looking for...
     
  3. Barrett Landscaping

    Barrett Landscaping LawnSite Bronze Member
    Posts: 1,597

    sounds like a short in the system to me. check all of your connections.
     
  4. f50lvr2

    f50lvr2 LawnSite Senior Member
    Posts: 277

    A short isn't out of the question I guess. I did check and clean or replace all connections when I put on the new solenoid so I'm still a little baffled. Taking it to a hydraulic place is a good idea, I'll look into that.

    Getting the bed repainted tomorrow so It's going to look brand new in a couple of days.
     
  5. Barrett Landscaping

    Barrett Landscaping LawnSite Bronze Member
    Posts: 1,597

    i had a similar issue with my insert. is it clicking when you try and lift it without the hot wire?
     
  6. f50lvr2

    f50lvr2 LawnSite Senior Member
    Posts: 277

    No clicking, nothing in fact until the lead is connected.
     
  7. N.H.BOY

    N.H.BOY LawnSite Bronze Member
    Posts: 1,604

    Ive got a F350 with a dump and this did the same for me. I switched out a new solenoid and still buttons on the controller didn't work. I was told the newer solenoids ground themselves so I had to run a wire out from my "down" button from the inside of the control and "touch" the end of that wire to a ground on the truck. Sounds weird, but damn it worked..:dizzy:
     
  8. f50lvr2

    f50lvr2 LawnSite Senior Member
    Posts: 277

    Interesting. I might play around with this idea when it gets back from paint. It does seem strange but we all know that electricity is like black magic sometimes.
     
  9. ecurbthims

    ecurbthims LawnSite Senior Member
    Posts: 467

    check for power coming and going from the switch or switches .
     
  10. N.H.BOY

    N.H.BOY LawnSite Bronze Member
    Posts: 1,604

    does the new solenoid have a little "push" button on it to run it when all the wires hooked onto it? Also meant to say the "up" botton NOT the down one...sorry
     

Share This Page