Dump body stuck up

Discussion in 'Trucks and Trailers' started by Nj shade, Jan 31, 2013.

  1. Nj shade

    Nj shade LawnSite Member
    from Nj
    Posts: 245

    Parked my truck on Wendsday, put the dump body up about half way so the rain could drain out, went today to lower it and it is dead. Went up no problem, no odd noises or anything just went up as usual. Today the controller from inside the truck is completely dead, no up or down, when pressing the buttons there's no noise from motor for dump or anything. Checked all connections. Cleaned all nuts that hold wires on with wire brush and still nothing.

    Any help and/or ideas as to what it could be are appreciated.
    It's an ABC dump body, not pto driven, hydrolic fluid not leaking from it at all.

    Thanks in advance!!!
     
  2. Marek

    Marek LawnSite Bronze Member
    Posts: 1,385

    We have had solinoids go up before and it would not let the body down.
     
  3. Nj shade

    Nj shade LawnSite Member
    from Nj
    Posts: 245

    Where would the solenoid be on the dump motor/fluid reservoir?
     
  4. Landrus2

    Landrus2 LawnSite Platinum Member
    Posts: 4,833

    On my ford is on the pump motor but I have seen them on fire wall just flow the cable that comes out of battery:waving:
     
  5. Nj shade

    Nj shade LawnSite Member
    from Nj
    Posts: 245

    What am I looking for when following from battery?
    Sorry all the questions, first time with a dump, first time with problems on the dump body.

    It's an 03 f550 with an ABC dump if that makes a difference
     
  6. DEPENDABLE LANDSCAPING

    DEPENDABLE LANDSCAPING LawnSite Bronze Member
    Posts: 1,343

    If you have no up nor down I would think you blew the dump body fuse. Most likely it is a inline fuse on the positive wire from the battery to the electric motor for dump body. Good luck
    Posted via Mobile Device
     
  7. Bigred350

    Bigred350 LawnSite Senior Member
    Posts: 781

    Get you a test light. And start searching for power. Somewhere you have lost a connection or bad relay.
     
  8. Nj shade

    Nj shade LawnSite Member
    from Nj
    Posts: 245

    Replaced solenoid and still nothing.
    Stopped working after had washed truck from plowing with power washer, went up no prob but now still dead.
     
  9. southern79

    southern79 LawnSite Member
    Posts: 91

    Any chance there is a kill switch located beside the seat that some one may have turned?
    Posted via Mobile Device
     
  10. Nj shade

    Nj shade LawnSite Member
    from Nj
    Posts: 245

    That was the very first thing I checked, wish was that easy
     

Share This Page