Echo 266 starts and dies when you try to give it gas

Discussion in 'Mechanic and Repair' started by PabsMaster, Jul 28, 2013.

  1. PabsMaster

    PabsMaster LawnSite Member
    Posts: 119

    Hello,

    I was on vacation enjoying colorado, when my buddy thats covering for me gives me a call and say the echo will idle, but when you try to give it gas it either wont speed up or it will for a bit but then it will just die on you.

    Anybody have a quick fix? If not im taking it back to the dealer its only 3 months old, and replacing it.

    thanks,

    pabs
     
  2. ArtLikeLandscapes

    ArtLikeLandscapes LawnSite Member
    Posts: 115

    Find the little black plug at the rear of the carb under the primer bulb located where the primer base is notched. Remove the plug it can be a pain but you can get it out with a pick or small screwdriver. There will be a flat head screw under it. Place a small flathead in the slot and turn till it runs. Most of the time it is counter clockwise but some have been clockwise.
     
  3. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,142

    And a second plug on top and do the same ccw....it is top one for accelerating and the other one for high end. Needs more gas....dealer may not know what to do.
     
  4. GlynnC

    GlynnC LawnSite Senior Member
    Posts: 798

    Ed, I've learned to trust what you have to say about Echo's, but are you sure the 266 has the top adjustment screw? Just bought a new one--still on 1st tank of gas. Found the high speed adj, but the top didn't look like my other Echos so I haven't tried to remove the plug on top. This seems to be an awesome trimmer.
     

Share This Page