ECHO 755 blower starves when hot

Discussion in 'Mechanic and Repair' started by khutch, Nov 13, 2009.

  1. khutch

    khutch LawnSite Senior Member
    Posts: 495

    Blower is a couple months old, after 30-40 min. continuous use, it acts like a fuel filter clog, will not run above idle. Thought it was a filter issue, but only does it after long use (??!?) New unit, haven't owned one before - Speaking of fuel filter, how do you get to the fuel filter? Used to Sthil were you just reach in and grab it!
  2. madmower

    madmower LawnSite Member
    Posts: 43

    sounds like fuel cap not venting try cracking the cap open when it hapens next

  3. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,204

    Best way to check fuel filter is pull the fuel line off at carb and suck on it to see if it is open. Doubt that is problem after two months more like the temp has changed and will need to tweek high needle valve on carb a little. Echo has a breather on it and if opening the cap fixes your problem replace the white colored breather......hooks on one of the lines going into the fuel tank. I would guess the spark arrestor is okay but this is a good time to take it out if it has one.
  4. topsites

    topsites LawnSite Fanatic
    Posts: 21,653

    30-40 minutes sounds like about that time, have you tried filling it back up
    when it starts to acting like that?

    All I know...
    Don't let them run out of gas, on that note, don't let them run low.
  5. khutch

    khutch LawnSite Senior Member
    Posts: 495

    Out of gas is not the problem.......Tank is good for about an hour and change.
    Fuel filter does not fix it, taking gas cap off to vent does not do it....Dealer thinks it might be bad ignition coil, so I will take it in under warranty. Still going to use it till it bogs down every day then switch to the Stihl 420 until leaf season is over.

Share This Page