Echo 755 loses power when hot...

Discussion in 'Mechanic and Repair' started by khutch, Jan 28, 2013.

  1. khutch

    khutch LawnSite Senior Member
    Posts: 495

    Not the spark arrestor screen....Seems to run again OK when it cools off a bit, starts right up, then loses power again after a few minutes of full power. Before the day ended tried to run at 3/4 power for a while, that seemed maybe to work not sure. Problem seems to be when running WTF open.
    Any suggestions?
     
    Last edited: Jan 28, 2013
  2. seabee24

    seabee24 LawnSite Senior Member
    Posts: 619

    Warrantee?
     
  3. khutch

    khutch LawnSite Senior Member
    Posts: 495

    No warranty - 3 years old
     
  4. Landrus2

    Landrus2 LawnSite Platinum Member
    Posts: 4,812

    Take a compression text see if it's good. If OK next step
    If you have another blower the same running good just swap the carburetor for text . You problem should be the carburetor :waving:
     
  5. khutch

    khutch LawnSite Senior Member
    Posts: 495

    What would be proper compression number?

    Thanks for great forums!
     
    Last edited: Jan 29, 2013
  6. Landrus2

    Landrus2 LawnSite Platinum Member
    Posts: 4,812

    Between 125 and 145 you good :waving:
     
  7. piston slapper

    piston slapper LawnSite Platinum Member
    Posts: 4,240

    Are there any damp or oily spots around the carb or the head.??
    Could be a leaky intake ...isoblock...or head gasket...that seals when it is cold..and progressively gets worse as the unit warms up..
     
  8. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,141

    What happens when you adjust the carb to give it a little more gas?
     
  9. herler

    herler LawnSite Fanatic
    Posts: 5,144

    If it's been sitting outside chances are the air filter's wet.
    Remove it and see what happens.
    Let it air dry, or replace it.

    Otherwise it could be the coil, they're lifetime warranty.
     
  10. khutch

    khutch LawnSite Senior Member
    Posts: 495

    Sure about that?? Dealer said no way..........
     

Share This Page