Echo edger spiting gas out muffler when starting

Discussion in 'Lawn Mowing' started by AuburnGuy, Sep 9, 2004.

  1. AuburnGuy

    AuburnGuy LawnSite Senior Member
    Posts: 279

    I tried to start my PE230 edger yesterday. It was more difficult to pull the cable the first couple of times, then it pulled. But.... it would not start. Every time i pull the cable to start it it spits gas out of the muffler and will not start. I will be taking it to the dealer unless you guys know what it might be. And its not a dificult fix. Any Ideas. I was just thinking the other day that my edger and trimmer have served me well so far. They are a little over a year old (Just out of warranty).

    thanks
     
  2. grass_cuttin_fool

    grass_cuttin_fool LawnSite Gold Member
    Posts: 3,504

    It sounds if the diaphram in the carb has gone bad and allowed the gas to fill up the cylinder with gas, hence why it was hard to pull, and there is so much fuel in there thatis why it is coming out the muffler and has fouled out the plug. That is my guess and I have never replaced one myself so I dont know how hard it may be to replace
     
  3. ThreeWide

    ThreeWide LawnSite Bronze Member
    Posts: 1,116

    Aubie,

    There was recall on Echo this past year. I know because my trimmer was having a fuel-related problem and did some research here. Took in to the service center last week and the problem is supposed to resolved now. Looks like your model is in the list.

    Have a look at this thread:

    Echo recall
     
  4. AuburnGuy

    AuburnGuy LawnSite Senior Member
    Posts: 279

    Well my edger is now working again. I went by the shop. he said it was the sun and heat causing too much pressure and it did not vent or something like that. Anyway, I tried it there and it started up. He said it happens occasionally. he also said it has happend on his shindiawa's. So i guess it is just one of those random things.
     

Share This Page