Echo gets hot and dies?

Discussion in 'Lawn Mowing' started by mtwcutt, Sep 10, 2007.

  1. mtwcutt

    mtwcutt LawnSite Member
    from OKC, OK
    Posts: 140

    Guys I have a cheap Echo a few years old and after a half hour of running it dies. After a brief cool down so to speak it will fire again and run for a while and same thing. Does this sound like a coil problem? SRM-210.
     
  2. Richard Martin

    Richard Martin LawnSite Fanatic
    Posts: 14,700

    Sounds like a coil problem to me.
     
  3. Charles

    Charles Moderator Staff Member
    Posts: 7,952

    May want to make sure the air vents are not clogged up too.
     
  4. Runner

    Runner LawnSite Fanatic
    Posts: 13,494

    The gas cap may not be venting properly. This happens at times, even with models that didn't do it before. Other than that, it COULD be a coil issue.
     
  5. bill w

    bill w LawnSite Member
    from Va.
    Posts: 198

    To rule out the venting problem, loosen the cap after it dies and see if it will start at that time.
     
  6. MuleCutter

    MuleCutter LawnSite Member
    Posts: 212

    listen to what the previous guys said. always check the gas cap first in times like this tho. just to be on the safe side i'd change the plug while you're at it just as a bit of "insurance".
     
  7. General Grounds

    General Grounds LawnSite Senior Member
    Posts: 902

    :) venting or coil, sounds about right. tony
     
  8. Andrew's Lawn Maintenance

    Andrew's Lawn Maintenance LawnSite Member
    Posts: 83

    ok im kevin the mechanic for andrews lawn maintenance i think it is yes the spark plug and the muffler seals might be gone or your rings are gone on the piston and scoring the side causing it to die. then when it cools down the rings set back to the original spot. so check those not the gas cap that has nothing to do with it thats a whole other animal
    kevin
     
  9. kjslawn

    kjslawn LawnSite Senior Member
    Posts: 618

    I had the same problem with my stihl rings were gone also coil was shot too 150 and good as new Kevin is right
     
  10. kjslawn

    kjslawn LawnSite Senior Member
    Posts: 618

    I had the same problem with my stihl rings were gone also coil was shot too 150 and good as new Kevin is right
     

Share This Page