Echo hedger carb issues

Discussion in 'Mechanic and Repair' started by cariboulou, Nov 11, 2006.

  1. cariboulou

    cariboulou LawnSite Member
    Posts: 160

    Hey just installed a rebuild kit for my echo hc1500 hedger, new primer bulb, and fuel filter. After priming I hear like a whining or air leak from the carb, its very faint I have to put my ear up to the air opening with the air cleaner off to hear it. I pulled of the vent and it almost popped off with some gas behind it. Do these echo vent things go bad often? When I try to run it with it off some gas bubbles out of the vent tube. Is this supposed to happen?
     
  2. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,304

    Vents go bad all the time....can check it by sucking on it and it should let air into your mouth but if you blow it should block. Did you take the carb completely apart and put in all the new parts? I sometimes see bubbles in the primer hose but should see them in vent line unless the unit is off and in the sun. Are you sure you got the gaskets back in place when you put the carb back on and screws tight?
     
  3. cariboulou

    cariboulou LawnSite Member
    Posts: 160

    Im almost positive I reassmebled carb gaskets and diaphrams right. Im I didnt it wouldnt work, right? After I assmebled everything I ran it and used it for about 8 to 10 min. I ran it without a fuel filter....then installed filter and it started with problems. Got it to run with fuel filter on but no vent. Going to try a new vent mon, cant be too expensive, and listen for noise again.
     
  4. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,304

    You should be able to take the white vent off and the unit will run fine. I think the only function of the vent is to let air in and block gas from coming back out when the unit is off. Sounds like you got something else going on.
     

Share This Page