echo PB260 edger bogging down.

Discussion in 'Mechanic and Repair' started by EagleLandscape, Apr 15, 2005.

  1. EagleLandscape

    EagleLandscape LawnSite Platinum Member
    Male, from Garland, Texas
    Posts: 4,347

    Ok my guys were telling me at full power the edger starts to cut out and eventually shuts off. Took a look at it today so I thought it was the spark arrestor. So i just went ahead and took off the muffler for a second, and still had the problem. Replaced the fuel filter with a new clean one, and ended up taking off the air box and running it wide open. Still wasnt able to run it at full throttle without it shutting off.

    what else could it be, bad piston ring? could it be the spark plug? but its only at full acceleration though.
     
  2. TLS

    TLS LawnSite Fanatic
    Posts: 7,937

    Fuel tank vent?
     
  3. EagleLandscape

    EagleLandscape LawnSite Platinum Member
    Male, from Garland, Texas
    Posts: 4,347

    could it be clogged whereit creates a vacuum like a gas can with one out where it stops the flow? do i just buy a new vent, or clean out the existing one. didnt think of that. could it be the piston ring? i mean it sounds like it has good compression, but i think it has to do with max power, (ie things that affect power)
     
  4. EagleLandscape

    EagleLandscape LawnSite Platinum Member
    Male, from Garland, Texas
    Posts: 4,347

    took off the fuel venting piece, still bogs down. anyone else got any ideas?
     
  5. UNISCAPER

    UNISCAPER LawnSite Bronze Member
    Posts: 1,426

    Sounds like it is running lean. If you have an adjustable jet, open it up until the engine runs at peak. If you have one of those POS new carbs that the EPA loves so much, you might have to clean it.

    Other possibilities, is if there is the slightest pin hole in the line you could be sucking air which will also lean the mixture.
     
  6. EagleLandscape

    EagleLandscape LawnSite Platinum Member
    Male, from Garland, Texas
    Posts: 4,347

    First off, I'm an idiot. I didnt check the spark plug, so I need to try that too. Um, where is the jet? This edger is a few years old, so I don't think its one of the new ones that came out in the past year or two. Right now my guys are back to the pe210, (21cc). I really need my 26cc one back up and running soon.

    Where is this jet thing? I adjusted the idle and it wasnt running to rich to start with. Checked the carb and it was all clean. I'm stumped, and I dont really wanna pay someone to fix it for me.
     

Share This Page