Echo Shred-N-Vac Blower crapped out on me

Discussion in 'Lawn Mowing' started by Envy Lawn Service, Nov 3, 2003.

  1. Envy Lawn Service

    Envy Lawn Service LawnSite Fanatic
    Posts: 11,062

    This thing has ran flawless every day since new. Cranked on first or second pull in the morning and on the first pull the rest of the day. Now all the sudden it won't crank period.

    I changed the plug just in case, double checked the air filter although I knew it was clean and made sure it was getting fuel. Still nothing. I don't understand.
     
  2. proenterprises

    proenterprises LawnSite Silver Member
    Posts: 2,297

    wow-sorry envy-take it back to the dealer asap (is it new--or relativly new) and have him look it over. I have long since wondered about these shred and vacs.

    I swear by echo-but never had any feedback on them.. Anyone else use them. What did you use it for envy?
     
  3. locutus

    locutus LawnSite Bronze Member
    from NC
    Posts: 1,266

    I had an Echo trimmer that did the same thing. It was the carb. New one cost me $100.00.
     
  4. mike9497

    mike9497 LawnSite Senior Member
    Posts: 954

    i had 2 of them.they lasted for about 2 hours.sent them back to home depot.went and bought a giant vac 16 hp loader lol
     
  5. proenterprises

    proenterprises LawnSite Silver Member
    Posts: 2,297

    mike-i assume that you werent using them to load your truck...were you lol.

    it looks like they are pretty much limited to that small little bag...and then when it fills up (which must be quickly) thats it. ?
     
  6. Curtis

    Curtis LawnSite Member
    Posts: 162

    Envy take the muffler off and clean the exhaust port and throw that screen away .
     
  7. Envy Lawn Service

    Envy Lawn Service LawnSite Fanatic
    Posts: 11,062

    Dang it!!!! I forgot to do that! That screen is always the first thing to go on my 2 cycle stuff. Thanks for mentioning that. I hope the ports aren't clogged.
     
  8. jajwrigh

    jajwrigh LawnSite Bronze Member
    Male, from Martinsville, IN
    Posts: 1,405

    I have never had a problem with echo products. I own a trimmer,a blower, and hedge trimmers. All of them run great and the trimmer and the blower see a lot of use.
     
  9. Envy Lawn Service

    Envy Lawn Service LawnSite Fanatic
    Posts: 11,062

    It's around 6 months old. It has been my #1 blower all season. It has been great for a quick clean up after mowing. Grab, one pull, jet around, blow everything off and back to the truck....much faster and much less trouble than a back pack for small stuff.

    The shred-n-vac feature is nice too. I used that a lot. It's a real backsaver for pre-mow trash pick up. It comes in handy for picking up shrub trimmings and sucking leaves out of bed areas. Just handy all around. The bag is pretty good size and the shredder blades do a good job of chopping, muching and compacting anything you pick up.

    However, I think the Stihl version is much better all around. I'll talk more about that sometime later.
     
  10. Martino

    Martino LawnSite Bronze Member
    from Midwest
    Posts: 1,772

    Envy:

    Check to make sure that the safety switch where the vac tube is inserted is making good contact. Sometimes dust prevents it from making good contact, and if it doesn't.....no go.
     

Share This Page