1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community on the Franchising Forum.

    Dismiss Notice

Echo SRM-210 problem, help?!

Discussion in 'General Industry Discussions' started by sodgod, May 10, 2005.

  1. sodgod

    sodgod LawnSite Member
    Posts: 107

    I'm having a problem with my echo trimmer. It idols fine put when i use it it runs at low throtal for a bit but then it just doesn't want to run high throtal. I pull the trigger but it just makes a low grrrrr sound and wants to shut off. Like i said it idols fine but as soon as i try and give it gas it just wants to give up it seems. Whats going on? can anyone help me out on this one. I've tried a few things and i'm gettin a little pissed off that nothing seems to work. ;) :dizzy:
     
  2. proenterprises

    proenterprises LawnSite Silver Member
    Posts: 2,297

    Does it always do this, or only when cold. You could try and feather the choke on and off and see if that helps. Otherwise, try and adjust the carb a little bit, and see how it runs at higher rpm's. Let me know how it comes out.
     
  3. Longstar

    Longstar LawnSite Member
    Posts: 62

    clean your spark arrestor screen on the muffler. A lot of times, this is clogged and won't let the exhaust out at a sufficient pace causing the sluggish run

    check your spark plug and gapping

    check your fuel filter in the tank to make sure it isn't dirty

    clean your air filter

    All these things need to be done ona regular basis to keep your trimmer working in optimal condition
     
  4. ince8728

    ince8728 LawnSite Member
    Posts: 249

    had the same prob w/ my 210, just sent it in for a tune up, good as new. This was it's 1st tune up since i got it so it was due. All the tune includes was what was mentioned already.

    On another note, what kind of heads do you guys use on ur trimmers, i just got a new spool for mine now the head is shot. Is there anythin easier than the traditional echo bump heads?
     
  5. Eddie B

    Eddie B LawnSite Senior Member
    from gone
    Posts: 859

    What type of gas are you using? Echo's are picky, 87 octane can foul up the carb.
     
  6. jbell113

    jbell113 LawnSite Senior Member
    Posts: 654

    Thats what all my equipment did after a couple months use and it turned out to be the spark arrester that was plugged up ....I would check that first
     
  7. Eho

    Eho LawnSite Member
    Posts: 205

    Happened to me twice before with my echo trimmer and I took it in both times. The guy told me that the exhaust was really dirty and needed to be cleaned out. If I were you I would try to clean the exhaust really well. If thats not it, take it in for a tuneup. It cost me about 40 bucks but they fixed that, plus gave it a tune up and it ran great. good luck
    EHO
     
  8. Up North

    Up North LawnSite Bronze Member
    from MN
    Posts: 1,063

    My 210 was doing the same thing towards the end of the season last year. Cleaned the arrestor and started using Oregon's "Only One" oil mix. When mixing this oil it is good for all ratio's, it's synthetic. Haven't had a problem with any of my 2-cycle stuff since, in fact they run better.

    Buck
     

Share This Page