echo srm 210 shocking the pizz out of me.

Discussion in 'Mechanic and Repair' started by lawnwizards, Aug 4, 2006.

  1. lawnwizards

    lawnwizards LawnSite Silver Member
    Posts: 2,434

    i have an echo srm 210. its about 2 years old. just recently whenever it gets good and hot it will shock you. at first i thought it had a hairline crack in the plug so i changed that to no avail. it only shocks when hot. can anyone steer me in the right direction as to fix this? thanks.

    randy
     
  2. Kevin at Atlas

    Kevin at Atlas LawnSite Member
    Posts: 2

    there is a crack somewhere in the plug wire. It may be hard to see. Wrap the area in electrical tape.
     
  3. lawnwizards

    lawnwizards LawnSite Silver Member
    Posts: 2,434

    thanks, i'll try that out right now.
     
  4. Jim@MilkyWay

    Jim@MilkyWay LawnSite Senior Member
    Posts: 472

    How many times have I told you; DON"T run that dern thing in a thunder storm!!:laugh: :laugh: :laugh:
     
  5. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,315

    Might also check the two kill wires to be sure they are connected good and no insulation off them. Ours do that on various model, not sure what is going on thought it might be the plug cap breaking down somehow.
     
  6. SLR

    SLR LawnSite Gold Member
    Posts: 3,218

    I know i joined this thread way late,but a tidbit..try checking things like this when it's dark outside to see where the fire arcs from the rubber..i did this on my chevy at night and presto,you could see immeadiatly which sparkplug wire was the faulty one.
     

Share This Page