echo trimmer no spark

Discussion in 'Mechanic and Repair' started by kal751, Jun 5, 2004.

  1. kal751

    kal751 LawnSite Member
    from mi
    Posts: 3

    my echo trimmer will not start. pulled the plug and checked for spark. none.... jumpered across the on-off switch and again checked for spark. none......any ideas on what to check next.?
     
  2. repair_guy

    repair_guy LawnSite Member
    Posts: 4

    If it's not the on/off switch,then unplug ground wire from the coil and try again(mite be grounding out to cylinder).If not that check for rust/debres on magnet of flywheel and ignition coil.This willkeep an engine from fireing too.
     
  3. ducky1

    ducky1 LawnSite Senior Member
    Posts: 252

    Are you checking the spark with the plug? If so meybe the plug is bad. The switch grounds out the coil to kill the engine so jumping across it wont help. Unplug the kill wire at the coil and see if you have any spark. If not, the ignition coil is bad. Also check where the coil bolts to the cly. to be sure it had good contact with the engine for a ground.
     
  4. kal751

    kal751 LawnSite Member
    from mi
    Posts: 3

    pulled the coil out and the housing was cracked and dirty. cleaned it up but still no spark...ordered a new coil today should be here wednesday. thanks for your help guys..
     
  5. kal751

    kal751 LawnSite Member
    from mi
    Posts: 3

    replaced coil and it runs
     
  6. cariboulou

    cariboulou LawnSite Member
    Posts: 160

    how old was your trimmer? What model and how much was the coil?
     

Share This Page