1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Echo Trimmer

Discussion in 'Mechanic and Repair' started by Dooly, May 10, 2004.

  1. Dooly

    Dooly LawnSite Member
    from Jamaica
    Posts: 2

    I gotta Echo that runs well at FULL THROTTLE only, will not idle or run inbetween?
    Thanks for the Help
  2. north in south

    north in south LawnSite Member
    Posts: 24

    try a carb kit, new plug, new air filter. the diapham might be too worn.
  3. smack

    smack LawnSite Member
    Posts: 3

    If it is a older trimmer it may have adjustment screws on the carb and the idle speed one may be out of adjustment. If it does, turn it in until it just sits then back it out about 3/4 turn and try it there or check the manual for the recomended adjustment.
  4. jrainw

    jrainw LawnSite Member
    from indiana
    Posts: 11

    Method for setting 2 stroke carb
    Start with both screws out 1 1/2 turns
    start and warm up
    adjust low speed screw until throttle response is good
    with a string head on the unit with string out to the proper length hold the machine at full throttle, turn the screw out until it "4 strokes", you will feel it as a miss. then turn the screw in SLOWLY until it just cleans up. Don't be tempted into turning the screw in to far, it will sound great but you aren't just leaning out fuel, your leaning out oil also. If the screws don't seem to change things much the most common problem is a restricted exhaust.
  5. Dooly

    Dooly LawnSite Member
    from Jamaica
    Posts: 2

    I gotta good place to start here-The one I got is a newer one an it was used VERY HEAVY,actually a little much for about two days straight-then used normal for a short while-someone else used it for a little then when I tried it again thatproblem(50 to60 hours use)-
    If my intuition is right I think its gotta tear or hole in the diaphram as diagnosed above-but I still am interested in the correct way to set the screws etc.on any model as well!
    and THANK YOU for taking time to help me with my problem.
  6. sneezer17301

    sneezer17301 LawnSite Member
    Posts: 3

    try cleaning the spark arrestor. it is a little screen inside the muffler.


Share This Page