echo

Discussion in 'Mechanic and Repair' started by moreira85, Nov 6, 2011.

  1. moreira85

    moreira85 LawnSite Member
    Posts: 154

    I have echo pb251. It's 2yrs old. I registered it but don't have receipt. Recently it starts and idles fine. When I press the throttle it bogs down. I replaced air and fuel filter, changed spark plug and new fresh gas mix but still no luck. Thoughts? Do I need receipt for warranty?
    Posted via Mobile Device
     
  2. GlynnC

    GlynnC LawnSite Senior Member
    Posts: 780

    Have you cleaned the spark arrestor and exhaust port. These are typical symtoms of blocked exhaust flow.
     
  3. moreira85

    moreira85 LawnSite Member
    Posts: 154

    No. I took the exhaust screen off but didn't clean.
    Posted via Mobile Device
     
  4. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,085

    I guess that meant you threw the screen away? Now get onto the high needle and adjust it a little CCW. The high needle is the one furthest away from the engine.
     
  5. DEPENDABLE LANDSCAPING

    DEPENDABLE LANDSCAPING LawnSite Bronze Member
    Posts: 1,343

    We had the same symptoms and ended up putting on a new carb. Good luck.
    Posted via Mobile Device
     
  6. moreira85

    moreira85 LawnSite Member
    Posts: 154

    Took exhaust off n the port is clean. Still no luck. Gonna have to bring it in.
    Posted via Mobile Device
     
  7. GlynnC

    GlynnC LawnSite Senior Member
    Posts: 780

    If it doesn't have carb adjustment screws, do a search on Echo carb adjustment. Sounds like the high speed needs to be opened a little.
     
  8. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,085

    Yes...he didn't tell us what model he has. I will bet that 90% of the problems people have with echo trimmers can be fixed with adjusting the hidden needles.
     
  9. stuck

    stuck LawnSite Member
    Posts: 6

    hate to hijack but i have (had) the same problem on my ppf210 echo power prunner. after searching on here i found the high fuel plug, took it out, took the needle out, cleaned it, and adjusted it while running. works great at full throttle again. it still runs funny at idle to 1/2 throttle. where is the low fuel adjustment? someone said its on the rotor (top black throttleblade piece?). i don't see a plug or something that can be adjusted there. this board is very helpful. thanks again.
     
    Last edited: Nov 8, 2011
  10. DEPENDABLE LANDSCAPING

    DEPENDABLE LANDSCAPING LawnSite Bronze Member
    Posts: 1,343

    Hey guys not to change the subject but can anyone explain to me how to start a new thread?
    Thanks
    Posted via Mobile Device
     

Share This Page