Electrical help

Discussion in 'Trucks and Trailers' started by Woodland, Oct 20, 2006.

  1. Woodland

    Woodland LawnSite Member
    from Maine
    Posts: 207

    I really don't know much about vehicle electrical systems so I was hoping to get a little advice.

    When I have my trailer hooked up to the truck all of the lights work fine on truck and trailer, but, if I put my headlights on, my dash lights come on momentarily and then go out. In reallity, what is happening is the fuse for my parking lamps blows, thus no front or rear parking lights on the truck and no running lights on the trailer. All of the other lights work fine. If the trailer isn't hooked up, no problems turning on the headlights. Where should I start looking for problems? The trailer is only two years old so I'm assuming the wiring on the trailer is all good (but I could be wrongly assuming).
     
  2. lawnboy30

    lawnboy30 LawnSite Member
    Posts: 92

    you no doubt have a short in a wire in the trailer. Check all trailer wires for bare spots or pinches.
     
  3. cet

    cet LawnSite Member
    from Toronto
    Posts: 89

    You have a short somewhere in your running lights on the trailer. Either one of the lights is corroded or the wiring is pinched or cut somewhere. The harness that plugs into the truck might also be corroded. Just went through this yesterday with my enclosed trailer.
     
  4. Woodland

    Woodland LawnSite Member
    from Maine
    Posts: 207

    Seems a dumb thing to mention now, but, one of the running lights on the rear of the trailer is missing the red cover (i.e. exposed bulb). Is this a likely candidate?
     
  5. cet

    cet LawnSite Member
    from Toronto
    Posts: 89

    If the cover is missing due to damage, the power wire might be touching the metal somewhere causing it to ground.
     

Share This Page