Everride Scorpion hydro problems

Discussion in 'Mechanic and Repair' started by Lawn Enforcer, Apr 4, 2011.

  1. Lawn Enforcer

    Lawn Enforcer LawnSite Silver Member
    Posts: 2,381

    I'm having troubles with my 2008 Everride Scorpion FX 34" with the 19hp Kawasaki. It seems like the hydro drive has lost a good amount of power, especially on the left side. We changed the oil with the recommended oil and with a filter from Everride, it seemed to help some, but not much. The thing that puzzles me is that the oil gets noticeably dirty in it, but on my other Scorpion I've never changed the oil and it's completely clean. We followed the correct bleeding procedure and tried adjusting them, but nothing seems to help. Any suggestions?

    Thanks!
     
  2. Lawn Enforcer

    Lawn Enforcer LawnSite Silver Member
    Posts: 2,381

    I forgot to mention that it still has good power in reverse, just not so much for forward drive. It also "chatters" when there is a lot of pressure put on the system.
     
  3. BCR840

    BCR840 LawnSite Member
    Posts: 244

    Are all tires inflated correctly? That makes a big difference. I had the same issue and that helped a lot. I had a lot less air in one of the caster tires and it would not track right or do hills.
     
  4. Lawn Enforcer

    Lawn Enforcer LawnSite Silver Member
    Posts: 2,381

    All tires are properly inflated too...
     
  5. Shasta Lake Landscaping

    Shasta Lake Landscaping LawnSite Senior Member
    Posts: 436

    Is the hydro belt tight?
     
  6. Lawn Enforcer

    Lawn Enforcer LawnSite Silver Member
    Posts: 2,381

    Not sure, I sent it out to my mechanic last week so I'll have to give him a call and get an update.
     
  7. Lawn Enforcer

    Lawn Enforcer LawnSite Silver Member
    Posts: 2,381

    Got a chance to talk to him, belts are tight, no signs of slippage. Pulleys are also good, basically he said all of the "easy fix" things were fine, and it will need a rebuild. He knows a guy that works at Parker so he was going to talk to him and see what it would take to rebuild it.

    Any other routes I should look at?
     
  8. corey4671

    corey4671 LawnSite Silver Member
    Posts: 2,931

    Yes I know this is an old thread, but I'm experiencing the same problem. Left side is weak. What did you end up having to do to your machine LE? Mine only has about 150 hours on it. Gets little use. Only on backyards with narrow gates.
    Posted via Mobile Device
     
  9. corey4671

    corey4671 LawnSite Silver Member
    Posts: 2,931

    bump...........
     
  10. matt arends

    matt arends LawnSite Member
    Posts: 16

    I have a 2010 model its doing same thing only on left side. Any updates???/
     

Share This Page