exmark erratic steering

Discussion in 'Lawn Mowing' started by shade23, Jul 8, 2009.

  1. shade23

    shade23 LawnSite Member
    Posts: 6

    I have a 2008 Exmark Lazer Z, XS with steering problems.
    Recently when my mower got to 120 hours I have been having a problem backing the mower. When I move either the left or right motion lever backwards, that particular tire will hesitate and than start spinning. It makes it very dangerous when working around obstacles.
    I changed the drive belt, replaced the hydraulic filter, checked all the adjustments according to the book.
    I have no leaks and the the suction lines appear to be tight.
    Any help would be appreciated as I do not want to leave it with a dealer for a month.

    Thank You:waving:
     
  2. Nosmo

    Nosmo LawnSite Bronze Member
    Posts: 1,216

    I don't have an X Mark but here is a couple things you might check.

    Make sure the relief valves on the pumps are tight. Get your manual and see how it advises setting the linkage for the hydros.

    Jack up the rear end with both wheels off the ground or concrete and use jack stands too if possible. Put a heavy weight like a concrete block on the seat to bypass the switch so you can start it while standing beside the mower. When you get it started put the handles in the neutral position and see if either wheel is creeping.

    If one is creeping follow the manual about adjustment of the rods.

    Nosmo
     
  3. mowerknower

    mowerknower LawnSite Senior Member
    Posts: 766

    There is a little square headed bolt that clamps the drive arm to the hydro pumps, tighten it down and you will be good to go.
     
  4. beano

    beano LawnSite Senior Member
    Posts: 425

    Check the steering dampners
     

Share This Page