exmark lazer charging issues

Discussion in 'Mechanic and Repair' started by zmt325, Sep 10, 2011.

  1. zmt325

    zmt325 LawnSite Member
    Posts: 2

    so we have a 60 inch lazer at the shop and it seems to be overcharging and blowing the stater fuse. I spent last night pulling it apart and testing everything. kohler powered.

    i discovered the harness going to the starter switch was cooked. so i bought a new key switch soldered and heat shrink all new connectors.

    it is overcharging. 15 dcv and 31-33 amps at fuse link, batt is about 14.8 dcv and also at the starter lead. ac volt reading @ the voltage regulator is like 40+
    so the first thought was the voltage regulator, so I replaced it. NOPE
    second thought was bad ground, broken wire or loose connection. NOPE

    so my question is what could be causing it to over charge and blow the fuse like this. is it common?

    my last thought is stater. we had allot of rain this week so my guys are out in full force trying to catch up. I sent this mower out with them to test it, I called the crew leader at 12:00 and it had blown the fuse again.

    i am going to test continuity on the staters them self tonight when the crews return. I also found this link on this subject and it has been super help full. just thought i would pass it on.
    http://www.simpletractors.com/service/kohler_electrics.htm

    if anyone has experienced this they know how much of a pita it can be to track a problem like this
     
  2. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    Your stator AC output is in specs, I would swap a battery from another unit into this one and test DC output again. A bad/shorted battery can play tricks on a charging system.
     
  3. zmt325

    zmt325 LawnSite Member
    Posts: 2

    did that very first. the crew leader came saying it would not start.. so i put the batt out of our spare ex lz.
     
  4. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    Okey......

    I still don't believe your issue is the stator according to your running AC output test, Do you have another unit you can swap the regulators with just to eliminate a possible faulty new regulator ?


    Also, What's the battery voltage after sitting a hour or so, And battery voltage on the center regulator post with key on engine not running ?
     

Share This Page