Exmark Navigator Steering help...

Discussion in 'Mechanic and Repair' started by teeroy, Nov 5, 2013.

  1. teeroy

    teeroy LawnSite Member
    Posts: 4

    Hi Guys

    Got a brand new 2012 first time ever driving one also so I'm not sure if its me or the mower.

    When I'm going forward and pull back on the left or the right lever
    after letting go to straighten up the mower will still trun the same way
    and slowly come back straight.

    I'm finding myself correcting it straight with the other lever.

    Is there an adjustment for this or is it normal
    its a little frustrating as I'm coming from a zero turn and it was way smoother

    also when stopping the blades the deck makes a grinding sound to slow the blades is this Standard?

    Thanks for the help

    Troy
     
  2. ed2hess

    ed2hess LawnSite Fanatic
    Posts: 13,083

    If it like a Walker there is a spring device between the bottom of he lever and the actuating arm on the hydro. If that device gets gummed up with debris it will restore slowly. In other words it isn't a positive connection. Just clean it up with some air... Clutches have devices on them to slow blades when you disengage and it is a scrapping noise.
     
  3. teeroy

    teeroy LawnSite Member
    Posts: 4

    I thought the deck sounded like that just wanted to be sure

    the mower only has 2.5 hrs so its really clean already

    Troy
     
  4. TPendagast

    TPendagast LawnSite Fanatic
    Male
    Posts: 7,563

    could be everything is stiff and new and hasn't "relaxed" and broken in yet, could be something was over tightened on assembly at the dealer? Can't be sure Im not riding it.

    The grinding thing is kinda normal (unfortunately) It sounds hideously weird, but its an odd feature that is somehow part of that style mower.

    Id take the machine back to the dealer and just ask them if the steering can be adjusted... maybe they have another one there you can drive them both in the parking lot (yours and the other one) to compare steering to see if its just yours?
     
  5. Exmark PR

    Exmark PR Sponsor
    Posts: 238

    We'd like to help but need additional information, such as serial number. Please call us at 402-223-6375. Or you can take it back to your dealer for adjustment.
    Exmark Customer Service
     
  6. teeroy

    teeroy LawnSite Member
    Posts: 4

    serial number is 312614571

    i'm taking it back to dealer today I played around with the spring return made no difference,
    its also started leaking hydro oil from the top of reservoir some how not sure if its related to the steering not responding...?

    a little disappointing a $18.5K AUD machine would be like this brad new

    Troy
     
  7. brosko

    brosko LawnSite Member
    Posts: 39

    Yeah thats kinda scary actually.
     
  8. teeroy

    teeroy LawnSite Member
    Posts: 4

    look like exmark had a recall on drive pumps or motors not sure which but this one sat in the dealership and didn't get done,

    so lucky me pays a **** load for a new mower only to send back to the dealer for repairs that could have been done while sitting in the shop!!
     

Share This Page