1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Exmark Navigator w/ 27hp kohler problems

Discussion in 'Mechanic and Repair' started by yfz45004101, Jul 11, 2009.

  1. yfz45004101

    yfz45004101 LawnSite Member
    Posts: 1

    I work with a lawncare company and he has an exmark navigator with a 27hp kohler motor on it. The mower has 975 hours on it. The mowers starts in the morning fine and after about 5 minutes of mowing it starts to bog down and if you turn the chokle on it will keep on running. After a few more minutes it will barely run on the choke. I shut the mower off and wait 30 to 45 seconds and start it up and it will run fine on no choke for about 5 minutes again and then do the same thing. Any help would be grateful. It is very frustrating.
  2. ricky86

    ricky86 LawnSite Bronze Member
    Posts: 1,840

    1) Lossen the fuel cap 2) Check flow from tank. 3) Replace fuel filter 4) check fuel pump impluse line. 4) Check pump output 5) Clean carb. Goes without saying, there is fuel in the tanks and the petcock is on.
  3. hd17f

    hd17f LawnSite Member
    Posts: 1

    hey whats the update im having simpler problems
  4. mdghs

    mdghs LawnSite Member
    Posts: 40

    The fuel pump in bolted to side or more of near the top of the engine on the gas tank side of your engine, grass,dirt and leaves get stuck,jammed,lodged under it blocking air flow. There is vent on the underside of the pump. Clean out the debris with a air hose or whatever you want to use. This is what happened with to my 05 Navigator 27hp 48 in this thread in 2009. I still own the machine with 1878 hours on it.

Share This Page