FC420 leaking oil on Ferris WB

Discussion in 'Mechanic and Repair' started by nbuzz, Aug 26, 2009.

  1. nbuzz

    nbuzz LawnSite Member
    Posts: 157

    Hey Guys, I recently picked up a DD hydro Ferris WB with the Kawasaki FC420v on it.

    I have a small oil leak, I think that is coming from the oil filter bracket? the leak is very slow but I end up with oil covering the rear deck of the mower. the main oil seal looks good. the whole engine is very clean, just not at the oil filter. I'd like to get it fixed before it gets worse.

    Any ideas? any information is appreciated. Thanks!
     
  2. nbuzz

    nbuzz LawnSite Member
    Posts: 157

    forgot one other symptom.. once the engine has run for an hour or more nonstop the leak stops.
     
  3. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    There are two O-rings part #92066-2097 sealing the oil filter adapter to the sump/pan, Those are easy enough to replace and see if it stops leaking. If it still leaks in that area you can figure on replacing the sump/pan gasket.
     
  4. nbuzz

    nbuzz LawnSite Member
    Posts: 157

    Thanks Rob! I will give it a shot. Is there a better place to order parts other than J-Thomas? my last experience with them left a bad taste in my mouth...
     
  5. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,024

    No dealers in your area ?

    I have found most all on-line mower parts houses are slow getting parts out, I waited 2 weeks two different times from two different places.....Boss need not know what I work on at home from buying parts from him.
     
  6. nbuzz

    nbuzz LawnSite Member
    Posts: 157

    there's one but He doesn't take me seriously... I don't like them and I don't want to give them my business.
     

Share This Page