1. Missed the live Ask the Expert event?
    Not to worry. Check out the archived thread of the Q&A with Ken Hutcheson, President of U.S. Lawns, and the LawnSite community in the Franchising forum .

    Dismiss Notice

Ferris 3100 not cutting very well

Discussion in 'Mechanic and Repair' started by tlc2002, Aug 3, 2010.

  1. tlc2002

    tlc2002 LawnSite Member
    from 53597
    Posts: 25

    I have a ferris 3100 that is not cutting very well, I put new blades on clean out deck but it seems like the grass is not getting cut not leaving a clean cut, I thought about trying to adjust the clutch but could not find the adjustment like on my other mower, could it be the clutch is going?
  2. topsites

    topsites LawnSite Fanatic
    Posts: 21,653

    Did you take the deck out of its transport position?

    I know, stupid question.
  3. Ruben Rocha

    Ruben Rocha LawnSite Senior Member
    Posts: 577

    Just a suggestion. I don't know much about ferris..
    Could be a belt slipping.
    Is the deck one or two belts.
    Or it could be a bad spindle causing to much drag on the belt which will cause the belt to slip.
    Or it could be the clutch.
    For me I would start with spinning the blades by hand one at a time and see if the belt slips on the pulley or the clutch is slipping.
    That should get you somewhere.
    Last edited: Aug 4, 2010
  4. tlc2002

    tlc2002 LawnSite Member
    from 53597
    Posts: 25

    I just checked by turning key to power but not running and turned on pto and I could turn the belt and feel the clutch turn so it must be the clutch going out I did check my other mower and could not spin
  5. Restrorob

    Restrorob LawnSite Fanatic
    Posts: 11,023

    ^^^^^^^That's not a very good test, You may have been turning the engine crankshaft......

Share This Page