Flash 8 Help please

Discussion in 'Digital Marketing' started by FERT-TEK, Mar 6, 2007.

  1. FERT-TEK

    FERT-TEK LawnSite Bronze Member
    Posts: 1,035

    Hellow fellas, I am having solving a flash 8 problem with a new website I am making. I have created a small movie that animates my logo across the front of a flash header. The movie is complete and saved to the computer but when I preview it in my browser it continues to loop over and over with no end and my navigation buttons roll as though the mouse is passing over them continually as well. This only happens when previewed in my browser and not in FLash 8 when I animate it there.
    If any of you have experienced this or have insight please post it here. PS this is my first attempt at making a website but am learning quickly. So go slow if you dont mind.
     
  2. freshfitz

    freshfitz LawnSite Member
    Posts: 5

    goto file -> publish settings under html there is a checkbox loop. It that doesn'w work you need to put a stop(); code in the fla file. Let me know i do tons of flash work

    http://www.vortexwebsites.com
     
  3. FERT-TEK

    FERT-TEK LawnSite Bronze Member
    Posts: 1,035

    I will check this evening but I know that there is a stop action in the last frame.
     
  4. freshfitz

    freshfitz LawnSite Member
    Posts: 5

    you may want to put this in the html between the object fields

    <param name="loop" value="false">
     
  5. FERT-TEK

    FERT-TEK LawnSite Bronze Member
    Posts: 1,035

    The loop checkbox was checked and there is a stop() action in the fla. file at the end of layer 30. Two questions

    1) after I clear the checkbox in the html tab for loop movie do I need to publish the settings or hit the OK button?

    2) Regarding the stop() action in the fla.file does it matter which layer the stop() action is placed? There are 18 layers in this movie.
     
  6. FERT-TEK

    FERT-TEK LawnSite Bronze Member
    Posts: 1,035

    I found this in the HTML already
     
  7. FERT-TEK

    FERT-TEK LawnSite Bronze Member
    Posts: 1,035

    I just received this error message when trying to use the script assist to insert a stop action on the movie. Hope this helps

    **Error** C:\Documents and Settings\Dave\Local Settings\Application Data\Macromedia\Flash 8\en\Configuration\Classes\toplevel.as: Line 66: The class or interface 'String' could not be loaded.
    intrinsic function MMExecute(expr:String);
     
  8. freshfitz

    freshfitz LawnSite Member
    Posts: 5

    Don't use the sting assist just put this line exactly

    stop();
     
  9. FERT-TEK

    FERT-TEK LawnSite Bronze Member
    Posts: 1,035

    What is a sting assist?
     
  10. freshfitz

    freshfitz LawnSite Member
    Posts: 5

    sorry i meant script assist
    If you can't get it and want to email me the .fla i can look at it.
     

Share This Page