ford 7.3 problem

Discussion in 'Trucks and Trailers' started by vaacutabove, Jul 20, 2012.

  1. vaacutabove

    vaacutabove LawnSite Bronze Member
    Posts: 1,006

    I bought a 97 7.3 with a dump on it what I think is a good price. It needed Reverse gear and a synchronizer no problem. However It does not have a lot of acceleration It is turbo but Im not sure what the problem is. Any Ideas. keep in mind I am not a mechanic but can hold my own just my first diesel
     
  2. dieseltech

    dieseltech LawnSite Senior Member
    Posts: 651

    Any other specifics besides "not alot of acceleration"?
    Posted via Mobile Device
     
  3. CLARK LAWN

    CLARK LAWN LawnSite Silver Member
    Posts: 2,526

    Old and/or low oil level, dirty fuel filter, restricted exhaust, exhaust leak before turbo, turbo not spooling up, charge air leak (lines or cooler). To many possibilities without knowing more info.
    Posted via Mobile Device
     
  4. vaacutabove

    vaacutabove LawnSite Bronze Member
    Posts: 1,006

    This week oil and filters will be changed. Just wondering if there was a common problem. I only get 10mpgthem loaded or not. I just got it not to long ago. Only has 140 k on it
    Posted via Mobile Device
     
  5. vaacutabove

    vaacutabove LawnSite Bronze Member
    Posts: 1,006

    The check engine light came on while pulling hills today but went off wen its turned off. If that helps
    Posted via Mobile Device
     
  6. KrayzKajun

    KrayzKajun LawnSite Fanatic
    Posts: 10,742

    Go to a diesel shop, and have them check it out. Post yur question on powerstrokenation.com
    Posted via Mobile Device
     
    Last edited: Jul 21, 2012
  7. dieselss

    dieselss LawnSite Bronze Member
    Posts: 1,548

    Was it at wide open throttle or pretty close to it when the light came on ? Did you put you hand over the exhaust and feel what's coming out. Any loud hissing noises while under throttle??
    Posted via Mobile Device
     
  8. slowleak1

    slowleak1 LawnSite Senior Member
    Posts: 532

    If its a 97 with a dump, I would assume its got a 4.10 rear. Maybe even a 4.56. If thats the case, you wont get much acceleration out of it, its geared low for heavy loads, and only makes about 160 hp tops. You need to check by the firewall and see if you see any soot around the turbo area, and check where the exhaust manifolds meet the up-pipes and up-pipes meet the y collector at the turbo.

    You can rule out any oil issues as a 7.3 wont run on low oil, since it uses a high pressure oil pump to fire the injectors.

    Fuel pressure could be low also, which is a simple fix. One good way to check and make sure you are getting fuel is to take the cover off of the fuel bowl. The fuel bowl is located underneath the cover at the front of the motor (where it says 7.3 powerstroke) Lift the cover up, and you will see a round black plastic cover about 4-5 inches in diameter. There will be a sqaure in the middle of it, where you will insert a 1/2 drive ratchet. Pull this off and make sure the bowl is full of fuel. Replace your filter while its out. When you replace it, make sure you only have ONE o-ring on the cover, otherwise it wont seal and you will spray diesel everywhere.

    Also make a trip to autozone and have them read the code, and come post it here and I will tell you what it is and how to fix it.

    7.3's are some of the easiest motors to work on, so just post a little more info and Im sure we can get it all figured out.
     
  9. KrayzKajun

    KrayzKajun LawnSite Fanatic
    Posts: 10,742

    Bravo! Good post doug. You find tht bucket of lights yet?
    Posted via Mobile Device
     
  10. slowleak1

    slowleak1 LawnSite Senior Member
    Posts: 532

    ope, actually just got in from looking. Its around somewhere:dizzy:
     

Share This Page